I installed Ubuntu 18.04 on my Mac mini (late2014) and when it boots, it goes directly into Ubuntu. However, it won't load. An error message states the following:

    failed to open \EFI\ubuntu\grubx64.efi - not found
    failed to load image \EFI\ubuntu\grubx64.efi: not found
    start_image() returned Not Found

I know for a fact that I haven't overwritten my partition of the Mac OS (I was very careful about this and double checked everything) but I didn't load rEFind in the Mac OS side before doing this. I have tried using the Apple commands such as option, command+r, and command+option+O+F to bring up the UEFI or other menus with no success and I keep getting returned to the screen error above. I have tried an Ubuntu live boot on USB and booting with a bootable USB containing rEFind iso and still get returned to this error screen.

I do not have a keyboard that has a USB connection port (all my stuff is Bluetooth) and I will try this tomorrow because I found somewhere that the new Mac minis don't load the Bluetooth keyboards until the kernel is loaded which may explain why I can't open the UEFI.

what I am looking for is any additional help that might solve the problem. I currently can't get into either OS or reinstall either of them. I really would like to get into using Linux, but I don't want to give up my Mac OS either. Please help!



Ok, I am not sure how I did it, but I was creating the boot utility to try and repair the missing file via a USB. I was holding option and shift after restarting the Mac mini and somehow I got to the Mac boot screen. It still has the Macintosh HD (as I thought it would). I will try to install Ubuntu again at a later time verifying that I have used rEFind boot manager for my dual boot. Thank you all for your help and edits ^^


First of all, try opening the "disks" application in Ubuntu, then check if there is a "Macintosh HD" partition. If there is, bravo, celebrate, dance, or kiss your dog because you didn't overwrite/single-boot Ubuntu.

Now, you can mount it in the meantime and get your stuff (obviously, MacOS apps do not work on Linux.) I, too, have the same problem because I do not have a USB keyboard. Notice that if you hold the option key or any MacOS related boot options don't work. That's because your keyboard and probably your mouse are Bluetooth devices.

Also, notice that you have to wait a while when your computer boots and/or you have to type, toggle, etc. your keyboard and hover or click your mouse. Because it's connecting to your Mac Mini.

My solution for you is this:

Change to a USB keyboard and mouse, or just buy a cheap keyboard (and probably a mouse), hold option, then kiss your Mac Mini because both of you are together again. Reply to me if you need more help.

  • I know the Macintosh HD is still there because I remember staying away from it during the install. however, I still don't know how to get into ubuntu to make the configurations to switch back to Mac OS – Robert Lee Arnold Jun 2 '18 at 9:10
  • I hate to say it, but you might have probably messed up the installation. Try buying a cheap USB keyboard and mouse and hold the option button when booting. – icebunny08 Jun 2 '18 at 14:04

There are some confusion here about what belongs to Apple and what is MacOS. When the system starts, the basic information about the hardware is located in "UEFI" - similar to BIOS but it is extendible. This is where "Refit" and "Refind" comes in.

failed to open \EFI\ubuntu\grubx64.efi - not found
failed to load image \EFI\ubuntu\grubx64.efi: not found

This is the Linux boot loader - "GRUB" looking for the EFI files. You can keep the GRUB and use Refit to manage the boot. You will then loos the ability to boot to specific versions of Linux. Refit can also install Windows for you and give you a "triple boot". It provides a simple graphic interface . Apple offers the service menu that includes "Disk Utility" and the "CMND+R"and the rest is coded in EFI. This is run in "single user Unix" so here you can repair the file systems and reset all file permissions. When Linux boots it is also in single user mode, run "dpkg()" and update the kernel.

EFI will load this and will need information about it all and use this to load the system the way you want it set up. The keys is what you have to press to stop in EFI and change whatever you have to change in the setup, like "fsck" on the main drive and installing a new OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.