I have Ubuntu 11.10 installed in dual boot in a MacBook Pro 5.1.

I have installed the xserver-xorg-input-multitouch Multitouch X input driver, but I'm not sure I like it (it's too sensitive and moves too fast). So I want to get back to the default touchpad settings, but I can't.

If I remove the Multitouch X driver via synaptics, the touchpad won't work anymore. I have tried installing gsynaptics+gpointing device settings, and also I tried installing Synaptics TouchPad driver for X.Org server but nothing works other than the Multitouch X (which is the one installed now, all the others are not).

Also, I don't have the "touchpad" tab under the "Mouse and Touchpad" settings anymore, it disappeared.

So, how can I bring back the default touchpad and the touchpad tab?



Type gksu gedit /etc/X11/xorg.conf at the terminal. Check for the section having to do with the touchpad. It should start with Section "InputClass" and end with EndSection with multitouch somewhere in the middle. Put # in front of every line of that section. Now quit gedit and reboot. You should be back to your old trackpad driver and see it appear in the Mouse and Touchpad settings of System Settings.

Basically what I think is happening is that this conf file is being read even after you deleted the Multitouch X driver. So it tries to initialize a nonexistent driver and thus your trackpad doesn't work.

  • Kind of worked, but not completely: I still don't have the touchpad tab in the mouse settings. What I did was add the # in all the lines of /usr/share/X11/xorg.conf.d/99-multitouch.conf (which is the file with the texts you described) and I did the same in /etc/X11/xorg.conf. Now the touchpad is working again as it was out-of-the-box, but the tab is still not there. – aderojas Feb 15 '12 at 14:09
  • Also, the two-finger-scrolling is not working, although I checked the option in Dconfig Editor – aderojas Feb 15 '12 at 14:18
  • Ok, so right now and after a while without touchpad, I got it working again with Multitouch. Maybe I should just stay with it, so... is there any way to just make it less sensitive? And to make the right click work? – aderojas Feb 15 '12 at 15:10
  • Solved, look at the full answer I wrote. Thanks again for your help! – aderojas Feb 15 '12 at 16:09

I figure it out, and I have back the default touchpad and the touchpad tab in Mouse Settings:

1) Using Synaptic Package Manager (install it from the Software Center if you don't have it) uninstall xserver-xorg-input-multitouch Multitouch X input driver. Then install gsynaptics+gpointing device settings and xserver-xorg-input-synaptics

2) Do what C S was recommending: type in terminal gksu gedit /etc/X11/xorg.conf, and add # at the beginning of each line. This will make all the lines be comments, as if they weren't there.

3) I had to do the same in /usr/share/X11/xorg.conf.d/99-multitouch.conf, which is the file start with:

Section "InputClass" MatchIsTouchpad "true" Identifier "Multitouch Touchpad" Driver "multitouch" EndSection

4) Restart your comtputer

Your touchpad should work again as when you first installed Ubuntu, and you should have the touchpad tab back in your Mouse and Touchpad settings. At least this worked for me.

Still, be aware that Multitouch driver allows you to drag and drop with two fingers, and to select text. I just don't like how sensitive it is, so if someone knows how to edit that I might give it a try again.

  • I personally use the mtrack driver, which allows two finger drag and drop. It was designed to be configurable , unlike the multitouch X (I think mtrack is actually a derived version of it). You won't be able to configure it using the settings menu, but by editing the conf file. Anyway, here's the link. Anyway, I'm not sure how your recent changes affects the instructions, but you seem to be able to experiment and figure things out :). – Chan-Ho Suh Feb 15 '12 at 16:33
  • I think you forgot about the link. I wanna to try it out and find the perfect Touchpad! – aderojas Feb 15 '12 at 22:17
  • Clicking on it doesn't work? – Chan-Ho Suh Feb 15 '12 at 22:31
  • My bad! It didn't work the first time, don't know why! – aderojas Feb 15 '12 at 23:26
  • Activating multitouch made the touchpad super sensitive and at the same time not sensititve to the first touch for me. – CMCDragonkai Jan 26 '16 at 6:45

I'm editing because my comment made no sense. So, apparently at the end I was running the mtrack driver. When I upgraded to Ubuntu 12.04, the touchpad wasn't working at all. I kind of reinstalled the drivers and it seems to work find now, except that I have no right-click. So I'm trying changing from multitouch to mtrack and editing the conf file and we'll see.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.