1

How do you replicate Virtual Super Resolution on Debian based distro? Or like anything what would make GUI scale to make GUI more productive..

Thanks for any help (☞゚ヮ゚)☞


INFORMATIONS

  • This setup has one 1080p 60' monitor that is practically not useble to work with this scale for intended workload (Gaming, Audio-visual production, etc..)

  • Temporary GPU - ATI Sapphire 7870 AND AMD Radeon 7870

  • AMD has two names for this GPU as far as i know.


TRIED SOLUTIONS

  1. Change font size

    • Helped, but not much.
    • I can scale fonts so that its practically unreadable, but GUI stays the same.
  2. Change icon size

    • Helped, but not much.
    • Same as fonts, GUI is the same.
  3. Switch from XFCE4 on KDE and change DPI for monitor in GUI

    • Helped a lot, but still i need it to scale below “1”.
  4. Modify xrandr for virtual resolution

    • it seems to work, but screen can render just 1/4 at a time and the rest is accesable by moving cursor to the edge of the screen. Or it has black screen on ¾ of set screen which are non-useble.
    • Tried command:
      xrandr --output DVI-I-0 --mode 1920x1080 --fbmm 2560x1440 --nograb --rate 60
    • Seems that 3D applications can’t use 2560x1440 and nothing changes. I try to find something usefull in man pages and i found command “--Transform”, but based on provided informations i don’t know how to use it and it seems that it doesn’t have intended effect. Image here: https://imgur.com/a/ZiyMAe4
  5. Generate resolution using umc (Universal Moderline Calculator) and add it as mode to xrandr, then run it.

    • Resulted in blackscreen same as cvr.
  6. using "--scale" in xrandr allows me to replicate Virtual Super Resolution. (thanks to @Lienhart Woitok)

    • The problem now is that i can't access that part of the screen with cursor, but apps seems to be able to.
    • Testing different presets in xrandr now.

PROBLEM SOLVED

  • PROBLEM SOLVED RUNNING

    xrandr --output DVI-I-0 --fb 2560x1440 --panning 2560x1440 --scale 1.333x1.333 --rate 60

(Don't copy+paste it into your system, try it with your variables!)


DISCLAIMER

I haven't found any simmilar article on this forum nor on the internet and i can't fix this issue by myself. (☉_☉)

  • Ubuntu MATE 18.04 is similar to Xubuntu but with full high DPI support. Try this: Ubuntu MATE vs. Xubuntu for high DPI screens – karel Jun 2 '18 at 7:20
  • 1
    @karel Thanks for tip, i try it in VM. (•̀ᴗ•́)و – David Košecký Jun 2 '18 at 7:26
  • xrandr has a scale option that might help you. xrandr --output DVI-I-0 --scale 0.5x0.5 or xrandr --output DVI-I-0 --scale 1.5x1.5 depending on which direction you want to scale. – Lienhart Woitok Jun 2 '18 at 8:33
  • @LienhartWoitok Man! that's a step to the right direction! Now the problem is that i can't access 3/4 of the screen with mouse, but i can see it. I try to modify xrandr for that. – David Košecký Jun 2 '18 at 8:58
1

I was able to solve the issue by executing:

xrandr --output DVI-I-0 --fb 2560x1440 --panning 2560x1440 --scale 1.333x1.333 --rate 60

(Don't copy+paste it into your system, try it with your variables!)

Special thanks to @Lienhart Woitok. ᕕ( ᐛ )ᕗ

0

In KDE Plasma (I'm using Kubuntu 18.04):

  1. Settings
  2. Display and Monitor
  3. Displays
  4. Advance Settings
  5. Scale Display

Move the slider to the scaling level you desire, click Apply, then reboot.

enter image description here

  • it's "Tried Solution" #3 It helped a lot, but i need it to scale on less then 1 to make it useble for my workload.. :/ – David Košecký Jun 2 '18 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.