I tried to install Ubuntu 18.04 on Acer TravelMate P278-MG, but it bootloops 1. It starts up, shows Acer logo 2. It says:

System BootOrder not found. Initializing defaults.
Creating boot entry "BootXXXX" with label "ubuntu" for the file "\EFI\ubuntu\shimx.efi"
Reset System

Where XXXX - number, depending on the BIOS configuration(I tried Legacy, UEFI with SecureBoot on and off, different boot devices(there is Linplus lite boot device, which is strange)) 3. goto 1.


I found the solution on another forum. Two steps. Select a UEFI file as trusted and given it a custom name. Then go to the boot menu and select it as first priority as described below.

PROBLEM SOLVED! It turned out the problem was in the bios settings. I switched "secure boot" on which unlocked few more options. One of them was "Select an UEFI file as trusted for executing" that's in the "security" tab. After that it showed me HDD0, I hitted enter and "EFI" showed up. After another ENTER it showed 3 folders "ubuntu", "microsoft" and "boot". The ubuntu folder contained "shimx64.efi", "grubx64.efi" and "MokManager.efi" I'm not very familiar what all of them were, but I chosed "shimx64.efi" which was then added as "trusted for executing". I went back to the boot tab and found "EFI boot0: ubuntu" or something like it. That's because I named the "trusted" UEFI file "ubuntu". I moved it up to first priority and everything worked like a charm. Thanks for the advices, they made me search for my own mistakes in the bios configuration.

  • this worked for me too, except in my case, the F12 boot menu was disabled in the BIOS, so I had to enable that before I could see the option in the F12 menu at boot; also, if selecting erase secure boot settings, erase has effect only upon exiting BIOS setup and saving changes and rebooting; in my case, only 2 options can be added, and the only way to change one or both is to erase (clear) them and then add another – jmarina Sep 9 '18 at 13:26
  • thanks! It works also for Ubuntu 19.10 fresh install on an empty SSD on notebook Acer TravelMate. – user2342558 Jan 9 '20 at 21:45

I want to add something to Melebius' answer for users with HP UEFI/BIOS:

In those cases, there is no option to choose a trusted UEFI file, however, there exists the option for a Customized Boot under the Boot Options menu. You have to add custom boot path and enter EFI\ubuntu\shimx64.efi. Then you have to change the boot priority and put Customized Boot on top of the list for UEFI Boot Order.

  • 2
    Thank you. It's solved my problem. – Mesuti Jul 2 '19 at 14:23
  • 1
    I also had to move the "Custom Boot" option above "OS Boot Manager" as suggested by Serhat Türkman. – timelmer Aug 20 '19 at 22:24
  • 1
    holy crap. i cant believe this worked. lol. thank you for this. in my case though, i used "grubx64.efi". it worked! – DPS Nov 26 '19 at 20:15
  • Thank you. Straight to GRUB now. – zx81roadkill Jul 15 '20 at 23:24
  • 1
    Same for me. This is the correct answer for HP machines. – mikabytes Sep 7 '20 at 13:29

Addition to the answer of @Xeno you have to GO to "BOOT ORDER" and MOVE the "Custom Boot" at the top of "OS Boot" it should be like:

  • USB
  • Custom Boot
  • Os Boot

It may be a lifesaver so I've felt the need to add this answer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.