fresh install of 18.04 after completely purging 16.04. Aplay plays audio. Sound test in sound settings works. system sounds work but browser sound and vlc/video player gives no sound output. edit : it was working till just before i plugged in hdmi to play on tv

  • Check/change volume with alsamixer on a terminal, move with the LEFT/RIGHT arrow keys to select an item, and increase the volume on every item with the UP arrow key. – bistoco Jun 1 '18 at 16:31
  • @bistoco I found a way to get it working on VLC player i.e. by changing the default output source in audio settings to speakers/headphones. But I still cant get it to work on browser. I have tried the pacmd command to set output source – yashC Jun 2 '18 at 6:34

Try to walk through Sound troubleshooting procedure . I'd try step 6 first. Install pavucontrol and look maybe you have some applications muted. Also try changing audio device back and forth.

| improve this answer | |

Okay so this is how i solved it :

under the


there happened to be multiple config files. I just moved the ones concerning the HDMI to a new folder within the directory, killall pulse and then reboot.

It is working now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.