I use pdflatex to produce many pdfs for my professional life. I'm getting mixed results on the font printing correctly when I print to a network HP 600 M602. I'm using the HP LaserJet 600 M602, driverless, cups-filters 1.20.2.

The following programs print just fine:

  • CUPS lpr command line
  • google chrome Version 66.0.3359.181 (Official Build) (64-bit)

The following don't work

  • evince
  • adobe reader 9.5.5
  • xournal and pdf's created by xournals annotate feature.

This is on ubuntu 18.04. I'd like to have a pdf reader preferably evince but I've had really bad luck with it in the past hence installing the obsolete adobe reader. My previous install 17.04 this worked fine, but I'm not sure if I set up something differently. Any suggestions welcome :)


At least for my computer it appears that the problem was purely a print-driver issue. The menu for this can be quite tricky to find so I'm posting it too.

Setings > Devices > Printers

Scroll all the way to the bottom and click Additional Printer Settings

Select the printer in question with a right-click and go to Properties

Under Make and Model click change and use the menu items to select a new driver. The driver I found worked best was

HP LaserJet 600 M601 M602 M603 Postscript (recommended)

Results may vary, my hypothesis is that the HP 600 M602 is a postscript printer and by using the following "driverless" PPD not all programs converted to PS appropriately

HP LaserJet 600 M602, driverless, cups-filters 1.20.2
| improve this answer | |
  • You may want to file a bug report for the "driverless" PPD. – user68186 Jun 5 '18 at 19:24
  • It seems unclear the "driverless" PPD is completely at fault. Where would you suggest filing it cups-filters, cups-filters-core-drivers or printer-driver-hpijs? I'm not sure which package it came from :) – N8tron Jun 5 '18 at 19:29
  • 1
    I don't know enough about this either. – user68186 Jun 5 '18 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.