3

I run gVim from the command line and have for many, many years. But ever since upgrading to Ubuntu 18.04, I keep getting a long string of this warning a while after starting gVim:

** (gvim:5924): WARNING **: 15:10:26.274: invalid source position for vertical gradient

It's rather annoying because I keep using the terminal afterward and would like the content that was there before to stay there.

I haven't found anything useful searching for this warning online. I have no idea where it comes from or what it means.

Any help really appreciated.

2
  • @SebastianStark: I actually don't know what exactly is the default theme is, but I tried a different one, much prettier at that, and the warnings went away. :) Thanks a lot! If you put your suggestion forth as an answer, I'd be happy to mark it as the correct answer.
    – Teekin
    Jun 17, 2018 at 7:07
  • That's why savvy users start graphical programs with &> /dev/null. Gvim is relatively tame; other programs spam the terminal to a much worse degree.
    – AlexP
    Jun 17, 2018 at 13:25

1 Answer 1

2

This can be caused by an incompatibility or bug of the selected gtk theme and/or the version of the gtk theme engine. You should be able to get rid of the error by switching to another theme, preferably the default theme that comes with your distribution.

Although not directly related, this bug report may be able to help understanding the underlying problem: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=751735

1
  • What do you mean by "theme"? I can't find this anywhere. You don't mean "colorscheme" do you? For me, I only ever want to use koehler, so changing that is not an option, but I also have this problem with the ridiculous WARNINGS polluting the terminal, and I would like it fixed.
    – Starman
    Oct 2, 2019 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.