8

Please note that I have tried all solutions in the below two links:

"Dummy Output" sound in Ubuntu 14.04

No Sound card detected in Sound Settings, although sound works

pulseaudio -k && sudo alsa force-reload does not solve the problem

pacmd list-cards shows 0 card(s) available.

When the sound was working fine on my 18.04 before, I tried to modify /etc/modprobe.d/alsa-base.conf in order to solve a different issue following this answer. But after my sound stop working I removed the added lines which blacklisted the drivers. Could this have caused my problem?

Please help me out, I cannot work without sound on my PC for long

Update:

Since I have Dual Boot on my PC, I booted into Windows in which also the sound was not working, the Windows troubleshooter couldn't identify the problem so I went in Device Managers and reinstalled the Realtek HD Audio Controller, It didn't solve my problem, the sound still wasn't playing but a remarkable thing that occured was when I booted back into Ubuntu 18.04, it detected a Built-in Audio

and now pacmd list-cards shows :

1 card(s) available.
index: 0
name: <alsa_card.pci-0000_00_1f.3>
driver: <module-alsa-card.c>
owner module: 7
properties:
    alsa.card = "0"
    alsa.card_name = "HDA Intel PCH"
    alsa.long_card_name = "HDA Intel PCH at 0xa1428000 irq 128"
    alsa.driver_name = "snd_hda_intel"
    device.bus_path = "pci-0000:00:1f.3"
    sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
    device.bus = "pci"
    device.vendor.id = "8086"
    device.vendor.name = "Intel Corporation"
    device.product.id = "9d70"
    device.product.name = "Sunrise Point-LP HD Audio"
    device.form_factor = "internal"
    device.string = "0"
    device.description = "Built-in Audio"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
profiles:
    input:analog-stereo: Analog Stereo Input (priority 60, available: unknown)
    output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
    output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: unknown)
    output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: no)
    output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5460, available: unknown)
    output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300, available: no)
    output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 360, available: unknown)
    output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 300, available: no)
    output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) Output + Analog Stereo Input (priority 360, available: unknown)
    output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: no)
    output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) Output + Analog Stereo Input (priority 5260, available: unknown)
    output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: no)
    output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 100, available: no)
    output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5200, available: no)
    output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) Output + Analog Stereo Input (priority 5260, available: unknown)
    output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 100, available: no)
    output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 100, available: no)
    output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5200, available: no)
    output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) Output + Analog Stereo Input (priority 5260, available: unknown)
    output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 100, available: no)
    output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 100, available: no)
    output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5200, available: no)
    output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) Output + Analog Stereo Input (priority 5260, available: unknown)
    output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 100, available: no)
    output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input (priority 160, available: unknown)
    output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 100, available: no)
    output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input (priority 160, available: unknown)
    off: Off (priority 0, available: unknown)
active profile: <output:analog-stereo+input:analog-stereo>
sinks:
    alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
sources:
    alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
    alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Built-in Audio Analog Stereo
ports:
    analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
        properties:
            device.icon_name = "audio-input-microphone"
    analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "audio-input-microphone"
    analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
        properties:
            device.icon_name = "audio-speakers"
    analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "audio-headphones"
    hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"
    hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"
    hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"
    hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"
    hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"

Despite detecting this 1 card now, I am still not being able to get any sound, please help out

4

Install music packages of rhythmbox and amarok with:

sudo apt install rhythmbox amarok

or if they are already installed then:

sudo apt install --reinstall rhythmbox amarok

As I know these packages have some more drivers.

Then reboot.

  • I didn't have the music packages of rythmbox installed and seems like the drivers in these packages may have solved the issue. Thank You! – Kewal Shah May 31 '18 at 15:14
  • @KewalShah - good to know, that answer was of good use. – dschinn1001 Jun 1 '18 at 0:04
  • I was having some static noise on my HP envy when I installed ubuntu 18. Your answer has actually reduced the frequency of the static noise. – PhillipMwaniki Jun 2 '18 at 10:56
  • @PhillipMwaniki - About different noises I dont have any clue. Am deaf here. But nice, if this thread is of help. – dschinn1001 Jun 2 '18 at 14:55
  • That's ironic. For once the word actually applies! – Francky_V Oct 10 '18 at 15:43
0

I had the same problem of not having any sound device detected, so no sound at all after updating ubuntu from 16. to 18.04

I searched for some solution and, to be honest, what I tried was kind of a compilation of some answers found, so I am not sure which one was the real solution.

What I did and found the sound working was:

sudo alsa force-reload

killall pulseaudio; rm -r ~/.config/pulse/*

then rebooted but before loading ubuntu, I made a quick pass from the other OS installed in dual boot, that is Windows 7, as this was a solution that worked for some other pal, so after one more reboot, sound is back.

0

When I installed Ubuntu 19.04, everything was good. After several updates, there is no sound anymore. I googled and tried many solutions, but there was no luck. I came across a post which mentions installing ubuntu restricted addons.

sudo apt-get install ubuntu-restricted-addons 

This command resolves my issue.

But under Firefox, Youtube still has no sound. It is another issue. @@

-1

I was having the same problem and I had tried everything but I couldn't resolve the problem. Then I figured out that it wasn't the driver causing the problem it was keyring password that I had provided.

So if you have tried everything, try to reset your keyring password to blank.

  1. Go to System > Preferences > Password and Encryption keys
  2. Right click the appropriate folder
  3. Click Change Password
  4. Put in your old password and leave the new one blank

and if it doesn't work and u have installed chrome remote desktop app

There is some problem with chrome remote desktop with Ubuntu. Getting back your system sound for all applications you should remove the extension from chrome and ubuntu both.

Run command apt remove chrome-remote-desktop or apt-get remove chrome-remote-desktop and restart your ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.