2

I recently updated my ubuntu 16.04 to ubuntu 18.04, but after updating, my TP Link T9UH wifi adapter doesn't work anymore. It didn't work perfectly before (see Install rtl8814AU driver on ubuntu 16.04), but after removing and reinstalling the driver now and then, it would work again. When I enter sudo dkms install rtl8814au/4.3.21 it returns

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make'......(bad exit status: 2)
ERROR (dkms apport): binary package for rtl8814au: 4.3.21 not found
Error! Bad return status for module build on kernel: 4.15.0-22-generic (x86_64)
Consult /var/lib/dkms/rtl8814au/4.3.21/build/make.log for more information. 

How can I get my wifi adapter working again?

When I try the solution given here: How to install an Edimax EW-7833UAC in 18.04 sudo dkms install rtl8814au/4.3.21 returns: enter image description here

  • This link might help: askubuntu.com/questions/1033825/… I'm about to try it myself as I have a similar problem. – Tony Whelan Jun 3 '18 at 5:27
  • Unfortunately that does not work for me. When I try that, my dkms status gives me: rtl8814au, 4.3.21, 4.15.0-22-generic, x86_64: installed (WARNING! Diff between built and installed module!) – Sjoukje___ Jun 5 '18 at 9:34
  • It works! I deleted everything and reloaded the driver and after that it worked again. Very happy now! – Sjoukje___ Jun 5 '18 at 12:57
5

I personally use (and recommend) the drivers from aircrack-ng. See aircrack-ng/rtl8812au (@ GitHub)
I recommend to use the version 5.2.20 which introduces a very useful feature: A unique module (88XX) to "rules them all" (chipsets 8821AU, 8812au and 8814au). edit: The master (default) branch is now v5.6.4.2 and it is the best option (unique module for all chipsets from realtek 88XX.au family)
In order to install the drivers you need first to install the dependencies:

sudo apt install build-essential
sudo apt install bc
sudo apt install linux-headers-`uname -r`
sudo apt install git

Then download the repository

git clone https://github.com/aircrack-ng/rtl8812au.git

Locate your shell in the downloaded repository

cd rtl8812au

Switch to the branch 5.2.20

edit: No need to switch branch now, default branch is the best option

Finally, compile and install:

make
sudo make install

Notice that a even more recent version: Branch 5.3.4, But I had some problems to get it works with 8814au. Hopefully it will be fixed in the future (if it is not already done).

| improve this answer | |
  • Linux Mint 19.2 (cinnamon), kernel 4.15.0-58, USB Wi-fi TP-Link Archer T9UH(EU) ver. 2 - works perfectly! Thanks! – p0rsche Aug 23 '19 at 9:30
  • I've tried this approach, but I'm getting terrible connection speed. I've tried to install various versions using DKMS. Do you have any suggestions? – Slava Fomin II Oct 22 '19 at 20:16
  • i can't do magic, you need to be much more specific... The post is from some time ago, the only advice i can give you is to not switch branch as the default branch is now the latest one and much more actual then the 5.2.20 – kcdtv Dec 28 '19 at 17:34
  • You're an everyday hero. – Lauri Elias Aug 17 at 7:37
2

I installed the following to get my USB WiFi-AC working - not sure if you require 8814 though.

sudo apt-get install dkms
sudo apt-get install rtl8812au-dkms

It worked OK using both netplan settings and through the GUI

| improve this answer | |
  • Any update about 18.04? – gtzinos Aug 7 '18 at 18:46
0

For this driver, here is what works for me every time on Ubuntu desktop 18.04 thru 20.04:

Make sure USB wireless device not inserted

  1. Update the system:
    $ sudo apt update

  2. Install required packages:
    $ sudo apt install git && build-essential

  3. Download the driver:
    $ sudo git clone https://github.com/gnab/rtl8812au

  4. Go to the directory:
    $ cd rtl8812au

  5. Do the next commands consecutively:
    $ sudo make clean
    $ sudo make
    $ sudo make uninstall
    $ sudo make install

Reboot and insert USB wireless stick

-Persists reboots

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.