7

I have at least spotify and docker installed via snap. Both of these fail with the same error message:

"cannot perform readlinkat() on the mount namespace file descriptor of the init process: Permission denied".

Some other snap apps work for me.

I am using 18.04 and have applied all updates. Neither rebooting nor reinstalling fix the issue. And nor does reinstalling snap itself.

I am unsure as to how to go about fixing the issue.

  • What's the output of snap version? I think perhaps you're possibly running an unsupported kernel. See bugs.launchpad.net/snappy/+bug/1709155 – popey Jun 1 '18 at 9:11
  • hello-world works. In any case, snap was developed by Canonical which is the Ubuntu owner isn't it? – Daniel Jun 4 '18 at 7:52
  • I have the same issue with telegram-desktop . Until recently it worked just fine. – Ivan Yarych Aug 4 '18 at 7:05
8
sudo snap refresh core --edge

Run the above command to update the snap core package.

For me after I updated my kernel to Linux 4.18 it did not work with the same error message but after running the above command all works fine.

You may need to reboot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.