4

I'm configuring KVM/QEMU on Ubuntu 18.04 using netplan. There is corporative dhcp-server that provide a lot of mandatory data in addition to ip/netmask. The issue is that a bridge on setup generates its own mac-address, so it doesn't get proper ip (and other settings of course) from corporative dhcp-server. So...

How to force bridge to take/clone mac-address from first physical ports added?
Or may be there is a way to assign mac-address manually for bridge via netplan configuration?

Thank you in advance...

1 Answer 1

3

Corresponding bug: https://bugs.launchpad.net/netplan/+bug/1718607

The current workaround use the match stanza. Bellow is an example (here with eno1 interface):

network:
  ethernets:
    eno1:
      match:
        macaddress: <LINK_MAC_HERE>
      [..]
  bridges:
    br0:
      macaddress: <LINK_MAC_HERE>
      interfaces:
        - eno1
      [..]

<LINK_MAC_HERE> mac address can be retrieved with the following command (just after link/ether): $ ip link show eno1

After setting this, you need either to reboot, or doing the following commands:

$ sudo ip link set br0 down
$ sudo brctl delbr br0
$ netplan apply
1
  • Thanks, saved my day.
    – alci
    Apr 29, 2020 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.