0

nvidia drivers on my kubuntu 18.04 dont work. I have tried apt install nvidia-driver-396 and apt install nvidia-driver-390.

nvidia x server settings is installed, but wont even open.

Changing drivers in driver management from nouveau to nvidia also doesnt work.

My GPU:

Nvidia Geforce mx150 2gb

5
  • What video card do you have in your system? Some older cards do not work with the newer drivers. You can also check on NVIDIA's website and see the newest driver they have listed for your chipset. Please edit your question and add more detail. – Terrance May 30 '18 at 18:19
  • i have pretty new gpu, specifically nvidia geforce mx150, driver is installed, terminal shows "nvidia-driver-396 is already the newest version (396.24-0ubuntu0~gpu18.04.1)." as i mentioned, nvidia x server settings is installed, but clicking on icon does nothing... command lshw -c video shows configuration: driver=nouveau latency=0 – Necho May 30 '18 at 18:29
  • Did you use the graphics-drivers ppa to install the drivers? Second half of this answer askubuntu.com/a/1030901/231142 You might need to do a clean install of the drivers by purging any nvidia drivers you have setup. – Terrance May 30 '18 at 18:33
  • Let's find out which card you use and what driver linux is using at the moment: lspci -k | grep -EA3 'VGA|3D|Display' and which kernel uname -r (please add the output to your question). – ejjl Jul 29 '18 at 17:44
  • This looks to be similar to a problem I had earlier, and solved: askubuntu.com/questions/1068612/… – Arno Aug 28 '18 at 9:13
2

First try to remove whatever you've installed:

sudo apt remove --purge nvidia-*

Then add the graphics drivers repository (for the latest Nvidia drivers):

sudo apt-add-repository ppa:graphics-drivers

Then try to let Kubuntu install the drivers:

 sudo ubuntu-drivers autoinstall

Reboot, see if it worked.

1

From the Linux Mint Blog: Be careful with Kernel 4.15.0-24. A critical issue causes some computers to boot really slowly, or not to boot at all. Ubuntu is aware of it and working on a fix. We’ve also received negative feedback from the 4.15 kernel series in Mint 18.x (based on Ubuntu Xenial). Although Ubuntu decided to switch the HWE series towards it, the 4.15 series doesn’t appear to support some proprietary drivers yet (nvidia-3.04 and nvidia-340 among them).

I've got a custom-bult system with Ubuntu Gnome 16.04 and when the update to the 4.15.0-24 kernel came out, my system would not boot. In the grub menu I chose the 4.13.0-39 kernel and the system boots OK. So after any updates that require re-booting, I havve to manually select the 4.13.0-39 kernel. An Nvidia drver issue.No biggie...

1

I had the same issue. I fixed it by removing the nomodeset parameter from the file /etc/default/grub.

So the line

GRUB_CMDLINE_LINUX="nomodeset" 

should be changed to

GRUB_CMDLINE_LINUX="" 

Then run sudo update-grub and reboot the laptop.

0

Have the same issue with k1100m, seems to be a kernel problem, for now, all you can do is either use noveau or downgrade your kernel. Also, don't forget to leave a bug report, that way we will get fixed faster

Also, Wayland doesn't support Nvidia anyway, so if you are on KDE go for Wayland, it has some neat features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.