2

I was running sudo apt update && sudo apt upgrade -y yesterday. There was an update for the package ebtables (I looked it up and apparently it is iptables but for Ethernet?). However, apt was failing to install it.

root@win10:~# apt dist-upgrade -V
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
   ebtables (2.0.10.4-3.5ubuntu2 => 2.0.10.4-3.5ubuntu2.18.04.1)
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/79.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 29277 files and directories currently installed.)
Preparing to unpack .../ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: warning: old ebtables package pre-removal script subprocess returned error exit status 1
dpkg: trying script from the new package instead ...
invoke-rc.d: could not determine current runlevel
 * Error: insufficient privileges to access the ebtables rulesets.
invoke-rc.d: initscript ebtables, action "stop" failed.
dpkg: error processing archive /var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2.18.04.1_amd64.deb (--unpack):
 new ebtables package pre-removal script subprocess returned error exit status 1
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried a reboot, sudo dpkg --configure -a, and sudo apt clean/autoclean/remove/install -f/update/..., but nothing worked.

What should I do now? Should I just hold the package (sudo apt-mark hold ebtables)? Is there a workaround to installing it?

  • Please edit your question to show a complete session demonstrating the error. Please be sure to include the complete, unedited error message, and exactly how you make the error occur. – user535733 May 30 '18 at 17:25
  • @user535733 I am not at my computer now, but I will do it before the end of today – vikarjramun May 30 '18 at 17:37
  • 1
    Same question (unanswered) on the Microsoft Community forum – OrangeDog Jun 2 '18 at 12:26
4

It shouldn't be needed under WSL because the tables are managed by the Linux kernel, and in WSL you're not using the Linux kernel. Can't seem to remove it because of this error, but you can safely ignore it.

Update: The pre-removal script and ebtables stop script have been fixed in the ubuntu package so that upgrading should now work.

http://changelogs.ubuntu.com/changelogs/pool/main/e/ebtables/ebtables_2.0.10.4-3.5ubuntu2.18.04.3/changelog

https://bugs.launchpad.net/ubuntu/+source/ebtables/+bug/1774120

https://github.com/Microsoft/WSL/issues/3274

7
sudo cp -p  /bin/true /sbin/ebtables       
sudo apt update -y
sudo apt upgrade -y

from: https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/errors-in-ubuntu-1804-on-windows-10/fe349f3d-3d58-4d90-9f8f-c14d7c12af8b

  • 1
    This should be the accepted answer – Salaros Jul 3 '18 at 17:56
  • @Salaros I just saw this answer, I would accept it, but I feel bad taking away 15 rep from a user with 26 rep. – vikarjramun Jul 4 '18 at 15:43
  • 1
    @vikarjramun and what about downvoting? You are loosing your rep too, but you have to do it. I firmly believe that Stackexchage resources are not about rep, but correct/best answers. – Salaros Jul 5 '18 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.