0

this is my first post so sorry for any tardiness.

I am trying to install this: Tree of Savior - Steam

Which requires Winetricks in the list of dependencies.

However when downloading the Steam installer .exe I am always getting this error:

> user1@unknown:/tmp$ ./winetricks steam -v
> ------------------------------------------------------
You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions
> of packages. If you encounter problems, please retest in a clean
> 32-bit WINEPREFIX before reporting a bug.
> ------------------------------------------------------
Using winetricks 20180513-next - sha256sum:
> e4b2f5e8703247ea422b9094293a754339fd63c890a82b777fb9dbb6b6b369b0 with
> wine-3.9 and WINEARCH=win64 Executing w_do_call steam Executing
> load_steam  Executing cd /home/user1/.cache/winetricks/steam
> Downloading
> http://media.steampowered.com/client/installer/SteamSetup.exe to
> /home/user1/.cache/winetricks/steam
> --2018-05-30 14:59:00--  http://media.steampowered.com/client/installer/SteamSetup.exe
> Resolving media.steampowered.com (media.steampowered.com)...
> 193.229.109.27, 193.229.109.25 Connecting to media.steampowered.com (media.steampowered.com)|193.229.109.27|:80... connected. HTTP request
> sent, awaiting response... 200 OK Length: 1573568 (1,5M)
> [application/octet-stream] Saving to: ‘SteamSetup.exe’
> 
> SteamSetup.exe      100%[===================>]   1,50M  1,42MB/s    in
> 1,1s    
> 
> 2018-05-30 14:59:01 (1,42 MB/s) - ‘SteamSetup.exe’ saved
> [1573568/1573568]
> 
> Executing cd /tmp
> ------------------------------------------------------
sha256sum mismatch! Rename /home/user1/.cache/winetricks/steam/SteamSetup.exe
> and try again.
> ------------------------------------------------------

I have tried the solutions here: winetricks sha1sum mismatch rename and try again

Here: Installing Winetricks on Ubuntu LTS 18.04 for Steam

Here: https://forum.winehq.org/viewtopic.php?p=47908

and in many other places. I have also tried re-downloading, re-naming et cetera. I cannot seem to find a way to successfully download and install this file.

Does anyone have any other ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy