0

`By trying to install dos2unix on ubuntu 16.04 I came across with this problem:

libc6-dbg:amd6Multi-Arch: same : Depends: libc6:amd6Multi-Arch: same (= 2.23-0ubuntu10) but it will be not installed

Typing sudo apt -f install, returns:

The following packages were automatically installed and are no longer required:

  aglfn gnuplot-data gnuplot-tex gnuplot-x11 libcxsparse3.1.4 libfltk-gl1.3 libfltk1.3 libgl2ps0 libglpk36
  libgraphicsmagick++-q16-12 libllvm4.0 liboctave3 libosmesa6 libqgis-analysis2.18.14 libqgis-analysis2.18.15
  libqgis-app2.18.14 libqgis-app2.18.15 libqgis-core2.18.14 libqgis-core2.18.15 libqgis-gui2.18.14 libqgis-gui2.18.15
  libqgis-networkanalysis2.18.14 libqgis-networkanalysis2.18.15 libqgis-server2.18.14 libqgis-server2.18.15
  libqgisgrass7-2.18.14 libqgisgrass7-2.18.15 libqgispython2.18.14 libqgispython2.18.15 libqhull7 libqrupdate1
  linux-headers-4.10.0-28 linux-headers-4.10.0-28-generic linux-headers-4.13.0-26 linux-headers-4.13.0-26-generic
  linux-headers-4.13.0-32 linux-headers-4.13.0-32-generic linux-headers-4.13.0-36 linux-headers-4.13.0-36-generic
  linux-headers-4.13.0-37 linux-headers-4.13.0-37-generic linux-image-4.10.0-28-generic linux-image-4.13.0-26-generic
  linux-image-4.13.0-32-generic linux-image-4.13.0-36-generic linux-image-4.13.0-37-generic
  linux-image-extra-4.10.0-28-generic linux-image-extra-4.13.0-26-generic linux-image-extra-4.13.0-32-generic
  linux-image-extra-4.13.0-36-generic linux-image-extra-4.13.0-37-generic octave-common

Use 'sudo apt autoremove' to remove them. The following packages will be REMOVED:

libc6-dbg:amd6Multi-Arch: same

0 upgraded, 0 newly installed, 1 to remove and 144 not upgraded. After this operation, 25.6 MB disk space will be freed. Do you want to continue? [Y/n]

Accepting this, returns:

dpkg: warning: parsing file '/var/lib/dpkg/status' near line 7478 package 'libc6-dbg:amd6Multi-Arch: same':
 'amd6Multi-Arch: same' is not a valid architecture name: character ' not allowed (only letters, digits and characters '-')
dpkg: error: --remove needs a valid package name but 'libc6-dbg:amd6Multi-Arch: same' is not: illegal architecture name in specifier 'libc6-dbg:amd6Multi-Arch: same': character ' not allowed (only letters, digits and characters '-')

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
E: Sub-process /usr/bin/dpkg returned an error code (2)

When I do upgrade, returns the following issue:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6-dbg:amd6Multi-Arch: same : Depends: libc6:amd6Multi-Arch: same (= 2.23-0ubuntu10) but it is not installable
E: Unmet dependencies. Try using -f.

apt-cache policy dos2unix, returns:
 Installed: (none)
  Candidate: 6.0.4-1
  Version table:
     6.0.4-1 500
        500 http://br.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

The problem now is that I can't do upgrade. I have tried do remove the package sudo apt remove libc6-dbg:amd6Multi-Arch, but no sucess E: Unable to locate package libc6-dbg:amd6Multi-Arch

Also I tried this Ubuntu fix dependency problems and did not work.

How can we overcome this? I dont even need to install dos2unix, but now I have trouble to install any other packge.

4
  • Please edit your question to include all those 'more errors'. The summary (dpkg error code (2)) is insufficient detail to understand the problem.
    – user535733
    May 30, 2018 at 12:00
  • Please add output of apt-cache policy dos2unix to the question.
    – N0rbert
    May 30, 2018 at 12:08
  • The problem still persists. I have edited the question Jun 21, 2018 at 18:57
  • Question updated! Jun 22, 2018 at 18:19

0

Browse other questions tagged or ask your own question.