16

Title says it all.

Since upgrading from 17.10 to 18.04 Alt+Tab works fine i.e. switches apps cycling forward. But Alt+Shift+Tab does not switch apps backwards.

I went to Settings > Shortcuts and noticed that the shortcut for Switch applications is Super+Tab.

I tried Super+Tab and Super+Shift+Tab and they worked as expected, but i'm hardwired to use Alt+[Shift]+Tab. So I switched this shortcut to Alt+Tab.

Still Alt+Shift+Tab only switches forward, and not backwards.

Changing the shortcut to Super+Tab again works as expected for both forward and backward switching.

Any idea how to make the Alt+Shift+Tab work for backward app switching?

30

That's because Alt+Shift+Tab in Ubuntu 18.04 is blocked by another shortcut.

Run this command to free the Alt+Shift combination:

gsettings reset org.gnome.desktop.input-sources xkb-options

source1 source2

7
  • 1
    I was starting to give up! Thanks. Worked like a charm :) – Thalis K. Jul 17 '18 at 7:18
  • 3
    It resets Alt + Shift toggle input source behavior – Piterden Oct 25 '18 at 1:24
  • @Piterden that happened to me too. Did you find a workaround where the two can coexist? For me each one precludes the other. – ErnestScribbler Oct 29 '18 at 14:23
  • Unfortunately I didn't. It's fokken GnomeShell. Honestly, I loved Unity. Why did they get rid of it? – Piterden Oct 30 '18 at 2:02
  • 2
    My problem was that I'd set Alt+Shift to switch langauge, which in results, disabled setting alt and shift in a shortcut together. I switched to Win+Space and the problem was fixed. Hope it helps some guys – imans77 Oct 27 '19 at 12:55
8

I was able to resolve it using Gnome Tweaks GUI.

Open Tweaks and go to Keyboard & Mouse, then click - Additional Layout Options: as shown here, ans then uncheck Alt+Shift under Switching to another layout section as shown here

That fixed it for me.

1
  • god bless you man, it worked! – Exile79 Feb 23 '19 at 17:00
4

I use Ubuntu 18.04 with KDE and the answer from dima.rus helped me diagnose the problem: it was caused by a conflict with the shortcut for keyboard language switching.

What solved the problem for me:

  1. Change the Main shortcuts in System Settings -> Keyboard -> Layouts -> Shortcuts for Switching Layout which was Alt+Shift. EDIT: Do not set it to the otherwise rarely used Caps Lock as once I mapped and started using it, in some rare cases it caused the keyboard caps lock mode getting enabled and stuck (as indicated by the keyboard's caps lock light indicator), and forced me to reboot. EDIT: or instead of reboot, just start Onboard (the KDE on-screen keyboard) and use it to press Caps Lock virtually.
  2. Set the Reverse to Alt+Shift+Tab in System settings -> Task Switcher -> Main -> Visualization -> Shortcuts
  3. Log out and in again to KDE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.