1

Tried upgrading Ubuntu 11.10 to 14.04. So far everything looks alright, lampp, ftp, web, openvpn server etc are all running ok but openssh server is not starting.

Tried manually start it (/usr/sbin/sshd -d), it threw out the error that openssl version not right.

OpenSSL version mismatch. Built against 1000004f, you have  1000106f.

The problem now is that I cannot delete the old package and install the new one. It keeps throwing out the Unmet dependencies error

So far I have tried

apt-get -f install
apt-get clean  & apt-get update & apt-upgrade

dpkg --configure -a
apt-get -u dist-upgrade   && sudo apt-get -o 
Debug::pkgProblemResolver=yes dist-upgrade

All with no success, it looks like I cannot get over this dependencies error.

  • Welcome to Ask Ubtuntu! Could you please edit your question to explain how you performed the release upgrade or tried to? What's the output of lsb_release -a and apt-cache policy libglib2.0-0? Thanks. – David Foerster May 30 '18 at 15:19
  • Could you please post text files, dialogue messages, and program output listings as text, not as images? If all you have is console access see How do I get information from the logs on my computer when I only have access to the command line? and/or How can I easily share the output of a command or a text file with others?. Thanks. – David Foerster May 30 '18 at 15:22
  • Thanks I will plug in a flashdrive tonight and get the relevant outputs and attach again. – Denistone May 30 '18 at 23:10
  • Thanks David, I just pasted the text output from "apt-get -f install" – Denistone May 31 '18 at 6:51
  • Have you managed to upgrade all the way from 11.10 to 14.04 or are you stuck somewhere in between? If you have, what were the stages? 11.10 -> 12.04 -> 14.04 or something else? What did you do to upgrade? What is the output of lsb_release -a? Please add all this to the question: you can edit it. – muru May 31 '18 at 6:52
0

ubuntu 11.10 has reached EOL "End Of Life" a long back so it can't take upgrades. Read this documentation for workaround https://help.ubuntu.com/community/EOLUpgrades

add or make sure that these repos are there in your source list /etc/apt/sources.list

deb http://old-releases.ubuntu.com/ubuntu/ natty main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse

run update upgrade command and perform sudo do-release-upgrade.

  • Thanks for your kind reply. Yes it is old and EOL. Currently I just want to get out of this situation but it seems that I am stuck here. Tried adding your suggested 3 sources, update reported some of them cannot be found, do-release-upgrade throws out a few lines of error, "authenticate 'utopic.tar.gz' against 'utopic.tar.gz.gpg'.... can not run the upgrade, the error message is 'No such file or directory' – Denistone May 30 '18 at 8:46
  • I think I already did the upgrade to 14.04 (trusty) which is a supported version. The problem now is that I have 4 packages complaining the depending packages either not in place or in the wrong version, the issue is within 14.04 as how to solve this package corruption, or 'unment dependencies' issue. Thanks. – Denistone May 30 '18 at 10:29
  • Try doing sudo apt-get install -f and it is throwing some errors maybe because those tar.gz files were installed manually by you(not so sure about that). This command might resolve your dependencies. and there are some things you have to download manually given in the above link (help.ubuntu.com/community/EOLUpgrades) kernel and other stuff try doing that stuff but i recommend re installing after backup. that would be easier and quicker. – Jatin-CBS May 30 '18 at 13:45
  • thanks I did try "apt-get install -f" before, it threw me back the error as showed in the pic. I don't remember I ever manually installed any packages, besides those offending packages appear to be system packages, and only 4 of them so far are complaining. If I can get over this step, rest could be fixed easily. – Denistone May 30 '18 at 23:13
0

Try apt-get install openssh-server openssh-client

  • Thanks, tried that before but it throws back the same message, unmet dependencies as showed in the picture. Thanks. – Denistone May 30 '18 at 8:51
  • Make sure your other SSL packages have the same version number that your openssl package does. Things like libssl1.0.0 and libssl-dev may have a higher or lower version if you've used non-standard repos like debian-testing. So if your openssl version is, for example, 1.0.1e-2+deb7u11, fixing this is as simple as apt-get install libssl1.0.0=1.0.1e-2+deb7u11 – remoteitguy May 30 '18 at 9:00
  • Thanks for the rely. The problem now seems that I can't run any 'apt-get install', anything such as install or remove will get me back that funny 'unment dependencies' error. I did check carefully with that dependencies error and wanted to fix those packages errors, the problem now is that I cannot remove or install package, it always complains those dependencies error. Also I don't know what are those packages, indicator-datetime, indicator-power etc, and how to get rid of them (other than apt-get remove). – Denistone May 30 '18 at 9:13
  • Try making note of those packages and then removing them. – remoteitguy May 30 '18 at 9:16
  • Sorry I didn't get you, or you didn't get me? I did make note of those offending packages, the problem now is that I cannot run "apt-get remove" command, it throws me back the 'unment dependencies' error. – Denistone May 30 '18 at 10:28
0

I finally got this issues resolved and here is how.

I first managed to install a telnet server so I need no longer to stay in my garage, to get the telnet server up running, I needed to install lots of packages manually with dpkg, (as apt-get is no longer working due to the dependencies error), also carefully work out the sequence and dependency.

Later I changed /etc/apt/sourcrce.list from a fresh copy of 14.04 systems, just treat the system as a fresh 14.04 system , the rest is to fix whatever issue with 14.04.

Ldconfig needed to be manually installed from libc-bin, once passed this step, apt-get if install got working and it fixed most of the issues itself.

Later openssh-server, openssh-client, openvpn etc, although they all showed installed but unable to start. I had to manually re-install those packages , luckily with most of the conf files in place, I don't need to fiddle those configuration items, the packages are all smart enough and just picked up the existing conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.