2

This question already has an answer here:

I have installed Scilab with sudo apt-get install scilab, and all went good until I tried to open the software, it just does not open, what I tried to do was install a new version of Java, and it make it kind of work, when I start it from the console like this:

cd /usr/bin
./scilab 

but it still having some kind of trouble, I want it to start with the icon, but it looks to be impossible, please help me.

Warning: Could not find Java package '/usr/share/java/jlatexmath-fop-1.0.6.jar'.
Some problems during the loading of the Java libraries occurred.
This could lead to inconsistent behaviours.
Please check SCI/etc/classpath.xml.
Gtk-Message: 00:21:02.501: Failed to load module "canberra-gtk-module"

also I tried to install the 6.0.1 version of Scilab from the page, but at the moment of opening Scilab from the bin folder, a error comes up, saying that Scilab can not make the main class of Scilab :/ heelp

marked as duplicate by Eric Carvalho, Fabby, Kevin Bowen, David Foerster, waltinator Jun 25 '18 at 4:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It is very bad, but Scilab is broken in Ubuntu 18.04 LTS out-the-box. See my answer with the fix. – N0rbert May 30 '18 at 8:33

Browse other questions tagged or ask your own question.