2

Title says it all really. I've tried using the gnome tweak tool, and I've also tried changing the lockscreen background from within the system settings. No matter what I do it seems to always default to the orange beaver default background.

I tried copying the file to /home nothing. Tried copying it to usr/share/background nope. This sucker refuses to change.

Any help would be deeply appreciated. This is pretty frustrating for something so simple.

  • This answer may help you: askubuntu.com/questions/859581/… – WinEunuuchs2Unix May 30 '18 at 3:24
  • 1
    The Gnome Shell Extension Dash to Dock wreaks havoc with the lock screen. If it's installed, get rid of it and see if that fixes the problem. – user728899 May 30 '18 at 3:45
1

Okay so I did finally get to an answer. Honestly, it's a bit hacky and I still don't get why it isn't changing my lockscreen BG like it should, but whatever...

Basically I started by opening the file navigator with root permissions:

sudo -H nautilus

then I navigated from the root directory to /usr/share/backgrounds and from there the lockscreen background that GNOME seems to be stuck on is called warty-final-ubuntu.png. I backed up that file, then copied the background I wanted and changed its name to that. It worked immediately.

Again, this feels stupid and hacky. With my lockscreen UI looking different from everyone else's, and the built in lockscreen background switcher not working in either the system settings nor the gnome-tweak tool, I feel like there is a deeper issue here that isn't being addressed. But nobody seems to really know, and this works for now I guess. So I'll just leave it at that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.