4

I'm running a Core i7-6500U with integrated Intel HD Graphics 520. Under GNOME, all animations, such as going to the activities screen, scrolling in Firefox, etc are choppy. Even videos don't play smoothly in VLC. My laptop has a built-in 4K LCD panel, but it's choppy even at 1920x1080. Is there anything I can do to make it more smooth, or is this just the limits of the GPU? Kernel is 4.16.9. inxi -G says

Graphics:  Card: Intel HD Graphics 520
           Display Server: x11 (X.Org 1.19.6 )
           drivers: fbdev (unloaded: modesetting,vesa)
           Resolution: 3840x2160@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           version: 4.5 Mesa 18.0.0-rc5

glxinfo |grep -Ei 'opengl|direct rendering' says

direct rendering: Yes
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.0.0-rc5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
  • i disabled the gnome animated effects and now its better. ... i have no problem with vlc video playback – cmak.fr May 29 '18 at 23:28
  • 1
    @dsstorefile1 done – jaltair9 May 30 '18 at 3:28
  • 1
    Kernel 4.16.9 was garbage for me. Try default 4.15.0-20 or whatever it is now. – WinEunuuchs2Unix May 30 '18 at 4:22
  • 1
    So after a lot of research and trying new things (including trying almost every other DE I could think of), I looked at intel_gpu_top and found that the GPU utilization was about 50% when scrolling Firefox at 1080p (which I somehow made much smoother), and maxed out at 4K, so I think that the integrated GPU simply can't handle the full 4K resolution smoothly. – jaltair9 May 31 '18 at 5:32
  • 1
    I ended up installing Mate, which while it isn't perfect (although maybe my standards are too high), is for the most part usable in 4K. intel_gpu_top only hits about 75% when scrolling. I still wish GNOME was more optimized though; I use it on my higher-end desktop and it's great. – jaltair9 Jun 1 '18 at 1:10
3

Ok, so usually you just need to create an xorg.conf and properly set the parameters in order to get a much more decent experience. In this case the parameters AccelMethod set to sna and the TearFree to true are what does the trick. Here's how to proceed in the terminal:

First step:

sudo mkdir /etc/X11/xorg.conf.d/ 

Second step:

Run the command

echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

This will create /etc/X11/xorg.conf.d/20-intel.conf file with content:

Section "Device"
 Identifier "Intel Graphics"
 Driver "Intel"
 Option "AccelMethod" "sna"
 Option "TearFree" "true"
EndSection

After that just reboot. Hope it helps.

| improve this answer | |
  • 2
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – abu_bua Aug 16 '18 at 22:33
  • Thanks indeed major improvement on Intel 630 (i5 integrated). One hint as some users may be in doubt when they find xorg.conf.d folder in /usr/share/X11 so far driver looks in both localisations for the config files, so /etc/X11/xorg.conf/d is also valid, even parallel to the – Piotr Czekalski Dec 4 '19 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.