I'm a new Linux user, and I'm using a web server with a software that requires PHP 5.6, creating an incompatibility issue that I have been trying to solve for at least two days now. I read up a bunch of threads here on it, but none of them really solved the issue. The Linux version I'm at is 18.04.

So, what I tried so far:

  • To uninstall PHP 7.2 using sudo apt-get purge php7.0-common
  • To disable the proxy using sudo a2dismod proxy_fcgi proxy (it returns that the proxy is already disabled)
  • To install PHP 5.6 using sudo add-apt-repository ppa:ondrej/php or sudo add-apt-repository ppa:ondrej/apache2, it installs it
  • After using sudo apt-get update, and using this sudo apt-get install php7.0 php5.6 php5.6-mysql php-gettext php5.6-mbstring php-xdebug libapache2-mod-php5.6 libapache2-mod-php7.0, I get the error:
    • I used this thread suggested on the comments, and the php5-compat helped, now at least when I try to unmount/mount (or whatever it's called) I don't get a "php5.6 module doesn't exist" anymore, and now if I do sudo apt-cache search php5.6 --names-only I get the list of packages for the first time.

Since I got that part done now, I'll consider it as done and see with the Oxwall people about their requirements. Thanks a bunch.

  • for any package you can search by: apt-cache search php5.6 as it does not return anything. It means there is no such package. – neferpitou May 29 '18 at 20:43
  • Which Ubuntu version are you on? – Thomas Ward May 29 '18 at 20:44
  • Yeah, I found that thread before, and tried that @user535733, no luck. Thanks for trying to help. – Luke Perez May 29 '18 at 23:23
  • 18.04, @ThomasWard. I added it to the thread. Thanks! – Luke Perez May 30 '18 at 0:37
  • Could you please edit your question to include the full, verbatim output of sudo apt-get update? Thanks. – David Foerster May 30 '18 at 14:49