I a pretty much new to the linux system and for some reason I can't create nor delete new files in my partitioned hard disk.I am dual booting Ubuntu 18.04 with windsows 10 and the partition of New Volume:D in windows also appears in ubuntu along with all its file but I can not create new files in this partion when I am using Ubuntu.

I have tried changeing the group ownership of the mounted drive to admin.

**abrar@abrar-Inspiron-5559:~$ sudo chgrp adm /media/abrar/'New Volume'

[sudo] password for abrar:

** then this appears**

chgrp: changing group of '/media/abrar/New Volume': Read-only file system**

Then i tried to change the write permission for the group

** abrar@abrar-Inspiron-5559:~$ sudo chmod g+w /media/abrar/'New Volume'

chmod: changing permissions of '/media/abrar/New Volume': Read-only file system **

but its clearly not working as I am still nt able to create nor delete any of my files from new volume.

some of u might onder why i did not use the UUID instead of New volume. This is what the terminal shows me when I do that

abrar@abrar-Inspiron-5559:~$ sudo chgrp adm /media/abrar/EC1C11281C10EEF8

chgrp: cannot access '/media/abrar/EC1C11281C10EEF8': No such file or directory

  • 1
    I think the UUID is only useful in /dev/disk/by-uuid/, but be aware that those are device files, not mounted filesystems. Do not change device file permissions. – Chai T. Rex May 29 '18 at 19:57
  • I'm confused. You say this is an external hard drive - like a USB drive - but then you say it's one of the partitions on your disk. And EC1C11281C10EEF8 is the UUID of an NTFS partition so you can't chgrp, chown, chmod, etc., an ntfs partition. If it's a partition on an internal hard disk I suspect the issue is here: askubuntu.com/questions/917695/… – Morbius1 May 29 '18 at 20:02

I've found this answer https://askubuntu.com/a/958491/830248 helpful to automatically mount other partitions in Ubuntu and to make the partitions writable.

I have Windows 10 and Ubuntu 18.04 on another partition of the same drive. If I hibernate Windows, or power-off the PC while Windows is booting, or Windows update pending, Windows fast startup feature may also cause this problem (as @Morbius1 pointed in a comment), then I cannot modify any Windows partition in Ubuntu. So please make sure you properly shut down Windows before booting Ubuntu.


Windows has a 'fast startup' feature that shutdow windows with a kind of hibernate but not full shutdown

to get your windows drives writable, you must full shutdown windows

hold Shift key while pressing the shutdown button of windows

you may disable the 'fast startup' feature from windows power control panel enter image description here

  • Yes , both of you were right. Its working perfectly now.Thank you :) – A13rar May 30 '18 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.