I need a way to change the boot-up and login screen resolution to 1920 x 1080 resolution. I have a 4K display on my laptop and can't read the text in the grub bootloader screen properly as they aren't scaled. Even the login screen have some qirkiness like it missed scaling the mouse cursor.

I figure I could solve this if I can just lower the boot-up resolution and login screen, but I don't know what's the best way to about doing this. In the past, I have changed the boot-up screen resolution via kernel boot command parameters and muck about with gnome gdm. But if I don't do things properly, the changes may be overwritten during regular Ubuntu update.

Please provide advice if you have experience in doing this. Thanks.

  • If they get overwritten by an update, you could simply repeat the process right? – WinEunuuchs2Unix May 30 at 2:45
  • In which way is your comment useful? No disrespect but these comments are better kept to yourself. – Alex Sep 28 at 21:24
up vote 2 down vote accepted

You don't mention which version of Ubuntu you're using. If you're using 18.04, there are a couple of things you can try.

The first thing to do is to make sure the resolution of 1920 x 1080 is supported in grub. To do that reboot your computer and hit Esc repeatedly until you get the purple screen with the recovery and grub options. Hit "c" to get a grub prompt. At the grub prompt, type:

videoinfo

and hit Enter.

Look at the list of "supported" resolutions, and make sure 1920 x 1080 is there. If so, type:

exit

to exit grub and boot.

The boot screen resolution is changed by changing your default grub settings. Open a terminal and enter:

sudo nano /etc/default/grub

Use the down arrow or Page Down until you see the line that looks like this:

#GRUB_GFXMODE=640x480

Below that line, enter the following, substituting the 1920x1080 for a supported resolution:

GRUB_GFXMODE=1920x1080
GRUB_GFXPAYLOAD_LINUX=keep

To save your changes, hit Ctrl+o, with "o" as in Ohio, not zero. To exit nano, hit Ctrl+x. Now, update grub:

sudo update-grub

That should solve the problem in grub, and won't be overwritten by an update. For the login screen, you may be able to fix it with the 4K settings in Ubuntu 18.04. Go Settings -> Devices -> Displays and set "Scale" to 200%. I'm not sure if that will affect the desktop manager or not, but it's the first thing I'd try.

  • 1
    18.04 is in the title... – WinEunuuchs2Unix May 30 at 2:43
  • @linux4me Yes, I'm using Ubuntu 18.04. I couldn't get the video modes to show when running videoinfo but that may be due to the fact that I have secure boot enabled. Nevertheless, I blindly set the graphic mode to 1024x768 and later to 1280x1024, both work (tried 1920x1080, doesn't work on my hardware.) After the bootloader, my problem persist, i.e., the login screen is still running at 4K resolution with scaling and the linux console (ctrl-alt-f3) also still running at 4K resolution which makes the text extremely small and very hard to read. – Bernard Wei May 30 at 18:15
  • @WinEunuuchs2Unix: It is now. : ) – linux4me May 30 at 18:26
  • Actually it was 2 hours before your answer. I checked before commenting :) – WinEunuuchs2Unix May 30 at 19:51
  • @BernardWei It sounds like you've got a lower resolution in grub, and you've answered the question regarding the scaling setting in Ubuntu; i.e., it doesn't affect the resolution for the login screen or in consoles. I think Ubuntu 18.04 uses GDM for the login screen. In the past, you could edit your /etc/X11/xorg.conf Screen Section, Subsection Display to set the resolution of GDM, but I don't know if that works now. Ordinarily, I don't think the xorg.conf file exists, though I think you may be able to create one. – linux4me May 30 at 20:02

Just want to add that I found a way to change the login screen resolution. That part of my problem has been asked and answered, see how to change gdm3 thread.

After setting up the monitor resolution and zoom level I wanted, I simply copy the settings to gdm3 .config directory, make any further changes you need and then reboot the PC.

sudo cp -i .config/monitors.xml /var/lib/gdm3/.config/
sudo vi /var/lib/gdm3/.config/monitors.xml

You probably also need to do the following before rebooting. Select gdm3 when prompted.

sudo dpkg-reconfigure gdm3

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.