1

Firefox is much slower after the upgrade, and htop tells me that Firefox mostly uses only one CPU core, instead of distributing the load. Most importantly, Facebook is next to unusable after the upgrade to 18.04.

Steps I've already taken:

  • Enabling hardware acceleration in about:config
  • Using uBlock Origin to mitigate requests and traffic from third-party sites (as I did before)
  • Installed intel-microcode
  • Installed the Nvidia GPU drivers through Settings Manager

Incidentally, Core 4 seems to carry most of the Firefox load. I've never seen it jump to another core.

  • WTF. Now Firefox is blinding fast again. As a stopgap measure, I installed {chromium-webbrowser}, and so Firefox knew the end was nigh. In a last glimpse of fury, Firefox reared its head and was fast again. I don't understand computers. – user258532 May 29 '18 at 23:41
  • ...now, it's there again. Now I understand computers even less. – user258532 May 30 '18 at 6:54
1

Go to the firefox > Edit > Preferenses > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser

0

I've installed the 4.16.13 kernel from kernel.ubuntu.com/~kernel-ppa/mainline and it seems to work now...

...it was so frustrating.

Edit: No, this didn't really solve the problem either, after longer observations.

What I did now was:

sudo apt purge linux*

Attention, this step alone will make the computer un-bootable! Don't forget the next line:

sudo apt install linux-headers-generic linux-image-generic linux-tools-generic

Now, Firefox works much more fluent, and Firefox loads are evenly distributed over all CPU cores.

I will observe... again.

  • It still works. It still works. It still works. Blessed be 4.16.13. – user258532 Jun 14 '18 at 11:31
  • I am facing the same problem of slow loading of firefox in 18.04 LTS. I do not have NVidia. My desktop is on: Quad core i5 4440, 3.1 GHz. RAM 15.4 GiB. Kernel 4.15.0-24-generic. Can anybody please help with tutorial? – bluepearlsky Jul 10 '18 at 16:07
-1

I turned off Bluetooth found below Wi-fi settings. That fixed it for me. Os-Ubuntu 18.04 LTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.