32

I have this laptop that doesn't handle the backlight very well.

In /etc/default/grub, I have added a acpi_backlight=vendor function to get it to work at all. Which is cool, and the backlight now actually works, but the minimum backlight setting is still pretty high.

Is there any way to decrease the backlight below minimum? I don't mind having to type in the terminal to do that, as I won't need to do it often (just at night etc.)

31
  1. Open Terminal

  2. Enter the following command:

    cat /sys/class/backlight/intel_backlight/brightness
    
  3. Write down the resulting value (12421 in my case)

  4. Divide value by 6 and write it down (2070 in my case)

  5. Enter the following in the terminal, replacing 2070 with your value:

    sudo su -c "echo 2070 >/sys/class/backlight/intel_backlight/brightness"
    
  6. Close Terminal

  7. For future usage of the last command, open Terminal, press Ctrl and R together, start typing brightness. When the last command appears, just press Enter.

It works for me on a Samsung NC110 with Ubuntu 12.04.

  • Works for me in Ubuntu 12.04 on a Macbook Air (integrated Graphics only). However, pressing any brightness level button seems to reset this setting, i.e. pressing "brighter" does not increment from the brightness setting applied in the terminal, but from the "usual" minimum brightness that you achieve using the keyboard. Therefore increasing the brightness after applying this command results in a huge brightness increase. – king_julien Jul 28 '13 at 21:27
  • 1
    Aaaaaaaaaaaaaaaaaaargh. This setting resets itself automatically every few minutes. So you got to reapply it over and over. In it's current format this is not a practical solution :( Running it as a script periodically seems overkill though. I hope there's a better way... – king_julien Jul 28 '13 at 22:04
  • @king_julien, check my answer (askubuntu.com/a/394400), at the provided link I tell about some settings that may avoid resets. I'm not suffering any reset of this setting at my macbook pro. I suspect the reset has to do with the boot parameters. Since I've changed them, I'm not suffering a "reset" after unlocking the machine. – pepper_chico Dec 26 '13 at 16:55
  • 3
    Why divide by 6? On my machine I could reduce this value much more... – hoosierEE Feb 11 '14 at 17:46
  • 1
    sudo su -c "echo 2070 >/sys/class/backlight/intel_backlight/brightness" is the key, the number can go as down as 0. I use 80 on pitch black rooms. On 14.04. – quimnuss Nov 25 '15 at 12:14
15

None of the answers here worked for me (on a Dell Precision 5510). The output from cat /sys/class/backlight/intel_backlight/brightness for me was 1 and setting it any lower completely turned the screen off.

I finally found a solution from the answer here:

xrandr --output eDP1 --brightness .3

I was also able to get this to work on my external monitor (attached via a display port dock), and reduce it below the minimum brightness allowed by the hardware controls on the monitor:

xrandr --output DP1-1 --brightness .6

Note that your display might not be eDP1 (or DP1-1), but you can list all available displays by hitting tab twice after --output, or from xrandr -q which shows which ones are currently connected. Tweak the value for brightness, i.e., .4, .5, etc until you find a level that works for you.

  • How do you make this change permanent? – Prakhar Agrawal Mar 27 '18 at 13:41
3

Try to override the min brightness manually with

  1. sudo nano /sys/class/backlight/acpi_video0/brightness

  2. Change the value in this file to 0 (clear and type 0 if value is already 0).

  3. Press Ctrl + X to exit.

  4. Press Y and Enter to save the file.

This works for me. You can also try sudo sh -c 'echo 0 > /sys/class/backlight/acpi_video0/brightness'

I am still looking for a more robust approach. Any help is appreciated.

  • 1
    It doesn't seem to recognise the folder/file. I'm on Ubuntu 11.10, if that makes any sense to you. Thanks for caring to answer, though. – Ruben Bakker Feb 20 '12 at 20:35
  • 2
    I tried doing suggested. However the brightness still remains the same. In my case it was already 0 . Although I cleared and reentered as suggested. – bubble Nov 22 '12 at 17:42
  • This file does not exists in 12.04. – king_julien Jul 28 '13 at 21:21
  • Different GPUs / hardware have it in different places – Suici Doga Jul 7 '16 at 6:34
2

I'm not using Ubuntu but Debian, but sometimes (second screen plugin, gnome restart) the brightness drops to zero. So I've created an inotify enabled application (it consumes zero cputime while there is no change in brightness) and when there is the change and it is changed to zero (or lower some predefined level, which you can specify) it sets the brightness to some default level, which you can also specify.

Please find it at my github page: https://github.com/nuccy/zero_brightness_fixer

1

This tool is a slider utility to set /sys/class/backlight/intel_backlight/brightness:

Works for my intel based MacBook Pro.

0

Install xbacklight by typing the following in the terminal

sudo apt-get install xbacklight

then:

xbacklight -percentage

replace the word "percentage" with the number of your choice to decrease the backlight from 1 to 99. In contrast, you can also do:

xbacklight +percentage 

to increase the brightness by replacing the word "percentage" with a number between 1 and 100. For more information, run the following in the terminal:

xbacklight -help

I know that this is probably too late, but I hope it helps :)

  • 4
    This does not decrease the backlight below minimum. When I'm already an the minium and just step -1, the display shuts off. – king_julien Jul 28 '13 at 21:18
0

This app works for me for decreasing brightness well beyond the usual https://github.com/lordamit/Brightness

  • Looks interesting. Care to share your binary? – TenLeftFingers Dec 13 '15 at 23:52
  • @TenLeftFingers sorry, dont have that machine now. – user13107 Dec 14 '15 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.