5

After doing a fresh install of Ubuntu 18.04 (using GNOME), I installed virtualbox both through sudo apt-get install virtualbox

However, when I run it from the command line I get:

VirtualBox: supR3HardenedMainGetTrustedMain:
dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: 
libQt5Core.so.5: cannot open shared object file: No such file or directory

When I checked for Qt libs, I can see that they are properly installed since they have ii status.

dpkg -l | grep libqt5

ii  libqt5concurrent5:amd64                    5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 concurrent module
ii  libqt5core5a:amd64                         5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 core module
ii  libqt5dbus5:amd64                          5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 D-Bus module
ii  libqt5gui5:amd64                           5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 GUI module
ii  libqt5network5:amd64                       5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 network module
ii  libqt5opengl5:amd64                        5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 OpenGL module
ii  libqt5opengl5-dev:amd64                    5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 OpenGL library development files
ii  libqt5printsupport5:amd64                  5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 print support module
ii  libqt5sql5:amd64                           5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 SQL module
ii  libqt5sql5-sqlite:amd64                    5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 SQLite 3 database driver
ii  libqt5svg5:amd64                           5.9.5-0ubuntu1                      amd64        Qt 5 SVG module
ii  libqt5test5:amd64                          5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 test module
ii  libqt5widgets5:amd64                       5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 widgets module
ii  libqt5x11extras5:amd64                     5.9.5-0ubuntu1                      amd64        Qt 5 X11 extras
ii  libqt5x11extras5-dev:amd64                 5.9.5-0ubuntu1                      amd64        Qt 5 X11 extras development files
ii  libqt5xml5:amd64                           5.9.5+dfsg-0ubuntu1                 amd64        Qt 5 XML module

However, the following libraries are not found:

$ ldd /usr/lib/virtualbox/VirtualBox.so | grep not
libQt5Core.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Widgets.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found
libQt5Widgets.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found
libQt5Widgets.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found

Same here:

$ ldd /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 | grep not
ldd: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: No such file or directory

Also:

$ dpkg -S /usr/bin/virtualbox
virtualbox-qt: /usr/bin/virtualbox

I then did a further search regarding Qt and reached this thread, but the solution doesn't work either: Ubuntu 18.4 libQt5Core.so.5: cannot open shared object file: No such file or directory

You can also see where the library files are pointing to:

ls -alht /usr/lib/x86_64-linux-gnu/libQt5*
lrwxrwxrwx 1 root root   24 Apr 14 21:31 /usr/lib/x86_64-linux-gnu/libQt5X11Extras.so.5 -> libQt5X11Extras.so.5.9.5
lrwxrwxrwx 1 root root   24 Apr 14 21:31 /usr/lib/x86_64-linux-gnu/libQt5X11Extras.so.5.9 -> libQt5X11Extras.so.5.9.5
-rw-r--r-- 1 root root  15K Apr 14 21:31 /usr/lib/x86_64-linux-gnu/libQt5X11Extras.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 14 21:23 /usr/lib/x86_64-linux-gnu/libQt5Svg.so.5 -> libQt5Svg.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 14 21:23 /usr/lib/x86_64-linux-gnu/libQt5Svg.so.5.9 -> libQt5Svg.so.5.9.5
-rw-r--r-- 1 root root 342K Apr 14 21:23 /usr/lib/x86_64-linux-gnu/libQt5Svg.so.5.9.5
lrwxrwxrwx 1 root root   25 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Concurrent.so.5 -> libQt5Concurrent.so.5.9.5
lrwxrwxrwx 1 root root   25 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Concurrent.so.5.9 -> libQt5Concurrent.so.5.9.5
-rw-r--r-- 1 root root  27K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Concurrent.so.5.9.5
lrwxrwxrwx 1 root root   37 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5EglFSDeviceIntegration.so.5 -> libQt5EglFSDeviceIntegration.so.5.9.5
lrwxrwxrwx 1 root root   37 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5EglFSDeviceIntegration.so.5.9 -> libQt5EglFSDeviceIntegration.so.5.9.5
-rw-r--r-- 1 root root 714K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5EglFSDeviceIntegration.so.5.9.5
lrwxrwxrwx 1 root root   30 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5EglFsKmsSupport.so.5 -> libQt5EglFsKmsSupport.so.5.9.5
lrwxrwxrwx 1 root root   30 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5EglFsKmsSupport.so.5.9 -> libQt5EglFsKmsSupport.so.5.9.5
-rw-r--r-- 1 root root  96K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5EglFsKmsSupport.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 -> libQt5Gui.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9 -> libQt5Gui.so.5.9.5
-rw-r--r-- 1 root root 5.4M Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9.5
lrwxrwxrwx 1 root root   21 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5 -> libQt5OpenGL.so.5.9.5
lrwxrwxrwx 1 root root   21 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5.9 -> libQt5OpenGL.so.5.9.5
-rw-r--r-- 1 root root 346K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5.9.5
lrwxrwxrwx 1 root root   27 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5 -> libQt5PrintSupport.so.5.9.5
lrwxrwxrwx 1 root root   27 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5.9 -> libQt5PrintSupport.so.5.9.5
-rw-r--r-- 1 root root 443K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 -> libQt5Sql.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5.9 -> libQt5Sql.so.5.9.5
-rw-r--r-- 1 root root 292K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5.9.5
lrwxrwxrwx 1 root root   19 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Test.so.5 -> libQt5Test.so.5.9.5
lrwxrwxrwx 1 root root   19 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Test.so.5.9 -> libQt5Test.so.5.9.5
-rw-r--r-- 1 root root 217K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Test.so.5.9.5
lrwxrwxrwx 1 root root   22 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 -> libQt5Widgets.so.5.9.5
lrwxrwxrwx 1 root root   22 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5.9 -> libQt5Widgets.so.5.9.5
-rw-r--r-- 1 root root 6.3M Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5.9.5
lrwxrwxrwx 1 root root   21 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5 -> libQt5XcbQpa.so.5.9.5
lrwxrwxrwx 1 root root   21 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5.9 -> libQt5XcbQpa.so.5.9.5
-rw-r--r-- 1 root root 1.1M Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5 -> libQt5Xml.so.5.9.5
lrwxrwxrwx 1 root root   18 Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5.9 -> libQt5Xml.so.5.9.5
-rw-r--r-- 1 root root 240K Apr 13 00:24 /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5.9.5

Any help?

  • did you try to remove/purge libqt5core5a then re-install it? ... See my 18.04 with Virtualbox from apt install files details : dpkg -L libqt5core5a and ll /usr/lib/x86_64-linux-gnu/libQt5* – cmak.fr May 29 '18 at 13:51
  • I checked and I have exactly the same outputs as yours. I then purged and reinstalled libqt5core5a, but still the same error. I should mention that purging libqt5core5a also removes virtualbox-qt , which I had to reinstall. Any other ideas? – Razvan Valentin Marinescu May 29 '18 at 14:10
  • ls -alht /usr/lib/x86_64-linux-gnu/libQt5* do not have same output as mine. Some files are missing on you machine. You should have a better look on it – cmak.fr May 29 '18 at 14:19
  • Made some progress. It seems that sudo apt-get remove libqt5core5a and then reinstalling that and virtualbox-qt resolved most of the missing dependencies. Strange that with purge it didn't work. I still have one dependency left though: libdouble-conversion.so.1 => not found ... I will try to fix that also by re-installing the library and will post an update. Thanks a lot! – Razvan Valentin Marinescu May 29 '18 at 14:43
6

Thanks cmak.fr for pointing me towards the solution. I had to reinstall the the libqt5core5a and libdouble-conversion1 packages. Note that this also removed virtualbox-qt, which had to be reinstalled:

sudo apt-get remove libqt5core5a
sudo apt-get install libqt5core5a
sudo apt-get remove libdouble-conversion1
sudo apt-get install libdouble-conversion1
sudo apt-get install virtualbox-qt

At the end, one can check with ldd /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 to see if there are other missing dependencies. If there are, try finding the corresponding package names and reinstall them.

  • I have exactly the same problem on a clean 18.04 install. I have tried remove/re-install libqt5core5a, libdouble-conversion1, virtualbox-qt to no avail. I would be nice if someone can post a complete list of steps to either, figured out what the problem is and/or list of steps to solve it. – malypetu Aug 8 '18 at 0:14
0

In my case (fresh Ubuntu 18.10 install) ldd showed that only libQt5Widgets.so.5 was missing, and running virtualbox would show something like this:

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libQt5Widgets.so.5: cannot open shared object file: No such file or directory

So it was pretty close to OP's error. So I had to:

sudo apt install --reinstall libqt5widgets5

But then I had an error pretty similar to one of above in this thread:

Qt FATAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted (core dumped)

After rising debug level with :

export QT_DEBUG_PLUGINS=1

It showed that I had to install another two missing dependencies:

sudo apt install --reinstall libqt5dbus5
sudo apt install --reinstall libxcb-xinerama0
0

Just to add information, these are the steps I have followed:

# Attempt to run virtualbox from terminal 
$ virtualbox

Qt FATAL: This application failed to start because it could not find or load
the Qt platform plugin "xcb" in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen,
vnc, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)

Finding the path to the executable

$ which virtualbox
/usr/bin/virtualbox

Find the program's shared libraries

$ ldd /usr/bin/virtualbox
not a dynamic executable

Use strace

$ strace  /usr/bin/virtualbox
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "**/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms**".

Available platform plugins are:....{ many plugins here }

The next thing I did (as suggested from another site) was:

$ sudo vim /etc/ld.so.conf.d/libc.conf
# libc default configuration
#/usr/local/lib         # comment it out this line

Then issue the following to update the library cache.

$ sudo ldconfig

Then try to run VirtualBox again from the terminal

$ virtualbox

Finally it works!!!

Hope this helps to fix your VirtualBox. Not sure if I have to uncomment the line /usr/local/lib from above.

Yes, I did uncomment the line

/usr/local/lib # comment it out this line

and everything continues to work fine. I did a reboot to do clean check all is well.

Cheers

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.