1

After upgrading from 17.10 to 18.04 my system freezes after login, sometimes but not every time..

The system boots until I see the login screen, but after entering the password, I'm greeted with a black screen that does not go away. Ctrl+Alt+F1/2/3 does not do anything, the only way out is Alt+Sysrq+S/U/B.

1 - It seems that the boot goes fine when I see (previous to login) the big Ubuntu logo, while if I don't see it the login screen appears just the same but it will fail after login 2 - When I boot into recovery mode, do choose grub, then choose resume login, the boot works fine (without the big ubuntu logo) 3 - Tried with nNivia 396.24 and 390 drives with same result

I run a Threadripper with GTX 1080 Ti system. Xorg logs at <link>, but the best hint I could find in there is

[ 15.858] (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission [ 15.858] (EE) NVIDIA(0): Failing initialization of X screen 0

Thanks for any help!

  • Just to update: this is still happening and I still don't have a solution. By now, I have updated to NVidia 396.54 drivers and 4.15.0-33-generic and it seems to be happening every time now. The only workaround that consistently works is to boot into recovery mode, run grub, then continue boot (and ignore the warning about graphics drivers). – Warner Aug 24 '18 at 5:46
0

Finally!

It seems that for now I've solved the problem by running (as user):

chmod 777 ~/.ICEauthority 
sudo dpkg --configure -a

Hope it helps somebody. To find this solution I used information found <here>.


Edit: maybe useful to add that I also changed grub, like this:

sudo nano /etc/default/grub

Change this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Save and exit, then run:

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.