This question already has an answer here:

I am using Ubuntu 14.04 LTS and I really need for my work to use Nvidia driver. My NVIDIA card is NVIDIA GeForce GTX 1050 Ti and I find in http://www.nvidia.com/Download/index.aspx that driver version 390.59 is the driver I should install.

After download the driver I run it and I have this error show in the image throw the link:

after I run the driver that I download from the official web

marked as duplicate by karel, Pilot6, Kevin Bowen, David Foerster, Ketan Patel Jun 23 '18 at 22:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


You must open a Console using next keys: CTRL + ALT + T change file to execute permission using next command: chmod a+x /path/to/nvidia/driver then from console: /path/to/nvidia/driver

Also you need to stop the GUI (Desktop) before install the driver : CTRL + ALT + F1 for GDM3 use: sudo /etc/init.d/gdm3 stop or for Lightdm: sudo /etc/init.d/lightdm stop then run the install: sudo /path/to/nvidia/driver

  • Thanks for your answer I have do all this and the installation completed successfully after that I reboot my PC . But when I write my true password and enter this show my login again and again without enter to the desktop :( any help ?! – Ahmad Mun May 29 '18 at 12:19
  • The cause is when you upgrade something related to .Xauthority with sudo, root will own this file and you cannot login as a user. Just press Ctrl + Alt + F1, login with your username and: sudo chown [your_username] /home/[your_username]/.Xauthority – Cornea Valentin May 29 '18 at 16:05
  • sudo chown user:user /home/user/.Xauthority replace user with your own user – Cornea Valentin May 29 '18 at 16:07
  • My user name is ahmad I wrote : " sudo chown ahmad:ahmad /home/ahmad/ .Xauthority" and I reboot after it and I have the same problem again ... ;( – Ahmad Mun May 29 '18 at 21:12
  • try, if you have lightdm: sudo dpkg-reconfigure lightdm or for gdm3: sudo dpkg-reconfigure gdm3, if that not work try to delete .Xauthority : rm /home/ahmad/.Xauthority then login again – Cornea Valentin May 30 '18 at 8:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.