1

I was using a friend's laptop with an Ubuntu 16 OS. I was asked to clean the historic files an after browsing a few websites, I used:

cat /dev/null > ~/.bash_history 

command which appear not to work (I was not asked to input any password). I then believe I used the command below, which I was asked to plug in the laptop's password:

sudo gedit .bash_history 

As soon as I pressed enter, the internet connection went down. I tried to connect the internet back, but the computer could not locate any wifi signal.

I appreciate any help you can give me to resolve this problem. Thank you.


Thank you so much for trying to help me with this. Please find the code you requested below:

X:~$ service network-manager restart
X:~$ dmesg | tail -n100
[    6.129998] systemd[1]: Listening on udev Control Socket.
[    6.130035] systemd[1]: Listening on fsck to fsckd communication Socket.
[    6.130088] systemd[1]: Started Trigger resolvconf update for networkd DNS.
[    6.130222] systemd[1]: Created slice System Slice.
[    6.130325] systemd[1]: Created slice User and Session Slice.
[    6.130340] systemd[1]: Reached target Slices.
[    6.130352] systemd[1]: Reached target User and Group Name Lookups.
[    6.130413] systemd[1]: Listening on Journal Socket.
[    6.148183] systemd[1]: Mounting Huge Pages File System...
[    6.148858] systemd[1]: Started Braille Device Support.
[    6.149766] systemd[1]: Mounting Debug File System...
[    6.150627] systemd[1]: Mounting POSIX Message Queue File System...
[    6.151304] systemd[1]: Starting Set console keymap...
[    6.152068] systemd[1]: Starting Create list of required static device nodes for the current kernel...
[    6.232277] systemd[1]: Starting Load Kernel Modules...
[    6.233014] systemd[1]: Started Read required files in advance.
[    6.316281] systemd[1]: Starting Uncomplicated firewall...
[    6.316430] systemd[1]: Listening on Journal Audit Socket.
[    6.317254] systemd[1]: Starting Journal Service...
[    6.780172] intel ips 0000:00:1f.6: i915 driver attached, reenabling gpu turbo
[    6.808348] systemd[1]: Started Uncomplicated firewall.
[    6.842875] systemd[1]: Started Create list of required static device nodes for the current kernel.
[    6.856450] systemd[1]: Starting Create Static Device Nodes in /dev...
[    7.002969] systemd[1]: Mounted Huge Pages File System.
[    7.003043] systemd[1]: Mounted Debug File System.
[    7.003944] systemd[1]: Mounted POSIX Message Queue File System.
[    7.053278] lp: driver loaded but no devices found
[    7.097062] ppdev: user-space parallel port driver
[    7.301544] systemd[1]: Started Load Kernel Modules.
[    7.316156] systemd[1]: Mounting FUSE Control File System...
[    7.317113] systemd[1]: Starting Apply Kernel Variables...
[    7.320741] systemd[1]: Mounted FUSE Control File System.
[    7.346084] systemd[1]: Started Journal Service.
[   12.482972] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   12.865049] systemd-journald[249]: Received request to flush runtime journal from PID 1
[   13.509733] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20150930/utaddress-254)
[   13.509745] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.509751] ACPI Warning: SystemIO range 0x00000000000011C0-0x00000000000011CF conflicts with OpRegion 0x0000000000001180-0x00000000000011E3 (\GPIO) (20150930/utaddress-254)
[   13.509758] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.509761] ACPI Warning: SystemIO range 0x00000000000011B0-0x00000000000011BF conflicts with OpRegion 0x0000000000001180-0x00000000000011E3 (\GPIO) (20150930/utaddress-254)
[   13.509768] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.509770] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x0000000000001180-0x00000000000011E3 (\GPIO) (20150930/utaddress-254)
[   13.509777] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.509779] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   13.959587] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   14.183140] kvm: VM_EXIT_LOAD_IA32_PERF_GLOBAL_CTRL does not work properly. Using workaround
[   14.703372] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
[   15.554781] input: Dell WMI hotkeys as /devices/virtual/input/input9
[   15.905234] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   15.905240] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   15.905243] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
[   15.905245] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   15.905247] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   15.905251] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x19
[   15.905253] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[   15.952201] input: HDA Intel MID Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   15.952300] input: HDA Intel MID Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[   15.952675] input: HDA Intel MID HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[   16.369490] media: Linux media interface: v0.10
[   16.509082] Linux video capture interface: v2.00
[   17.254476] uvcvideo: Found UVC 1.00 device Laptop_Integrated_Webcam_1.3M (0c45:6480)
[   17.273387] wl: loading out-of-tree module taints kernel.
[   17.273393] wl: module license 'MIXED/Proprietary' taints kernel.
[   17.273395] Disabling lock debugging due to kernel taint
[   17.276690] input: Laptop_Integrated_Webcam_1.3M as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input13
[   17.276871] usbcore: registered new interface driver uvcvideo
[   17.276874] USB Video Class driver (1.1.1)
[   17.278501] wl: module verification failed: signature and/or required key missing - tainting kernel
[   17.330064] wlan0: Broadcom BCM4315 802.11 Hybrid Wireless Controller 6.30.223.248 (r487574)
[   17.332446] wl 0000:03:00.0 wlp3s0: renamed from wlan0
[   17.556832] cfg80211: World regulatory domain updated:
[   17.556837] cfg80211:  DFS Master region: unset
[   17.556839] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   17.556842] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   17.556845] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   17.556847] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   17.556850] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   17.556853] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   17.556855] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   17.556858] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   17.556860] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   21.308688] audit: type=1400 audit(1528470507.538:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/ubuntu-core-launcher" pid=625 comm="apparmor_parser"
[   21.623559] audit: type=1400 audit(1528470507.854:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=621 comm="apparmor_parser"
[   21.623571] audit: type=1400 audit(1528470507.854:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session//chromium" pid=621 comm="apparmor_parser"
[   21.680192] audit: type=1400 audit(1528470507.910:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=622 comm="apparmor_parser"
[   21.680202] audit: type=1400 audit(1528470507.910:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=622 comm="apparmor_parser"
[   21.680208] audit: type=1400 audit(1528470507.910:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=622 comm="apparmor_parser"
[   21.680215] audit: type=1400 audit(1528470507.910:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=622 comm="apparmor_parser"
[   21.731800] audit: type=1400 audit(1528470507.962:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=629 comm="apparmor_parser"
[   21.827568] audit: type=1400 audit(1528470508.054:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ippusbxd" pid=631 comm="apparmor_parser"
[   21.847444] audit: type=1400 audit(1528470508.074:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="webbrowser-app" pid=628 comm="apparmor_parser"
[   22.344116] Adding 3001340k swap on /dev/sda5.  Priority:-1 extents:1 across:3001340k FS
[   36.321164] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   36.324656] IPv6: ADDRCONF(NETDEV_UP): enp4s0: link is not ready
[   36.333007] r8169 0000:04:00.0 enp4s0: link down
[   36.333052] IPv6: ADDRCONF(NETDEV_UP): enp4s0: link is not ready
[  241.448933] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[  241.453582] IPv6: ADDRCONF(NETDEV_UP): enp4s0: link is not ready
[  241.462678] r8169 0000:04:00.0 enp4s0: link down
[  241.462732] IPv6: ADDRCONF(NETDEV_UP): enp4s0: link is not ready

X:~$ /var/log/messages

bash: /var/log/messages: No such file or directory

X:~$ /var/log/messages

bash: /var/log/messages: No such file or directory

Update: 10/06/2018 Thank you George for your answer and for editing my previous entry. Please find below the requested code.

X:~$ is -la~/.bash_history

-rw------- 1 X 684 Jun 9 22:58 /home/X/.bash_history

I appreciate any further help to resolve this.

5
  • 1
    (1) unless you were opening webpages by passing the URLs to a browser on the command line, there's no reason for your .bash_history to contain information about your web browsing history (2) the cat command wouldn't need a password so that's not a reason to believe it didn't work (3) see Why should users never use normal sudo to start graphical applications? – steeldriver May 29 '18 at 11:20
  • Have you tried rebooting the machine after bleach bit or whatever you ran, If the network managers status failed, you may be dealing with a larger issue that just a simple clean up, As in It would help knowing his previous tampering with the network managers, not just gnomes. Two Network Mangers may be causing the conflicting if you can't get one or thee other up. – user610658 Jun 2 '18 at 6:37
  • With that being said though and as strange as it may sound, any USB plugged devices can disrupt the services if they experience an error in operation, so If any hotplugs are in, try unplugging them, rebooting the machine and then running service network-manager restart and service networking restart followed by a status check, It's happened to me before :/ – user610658 Jun 2 '18 at 6:43
  • Hi hello moto I tried your suggestions above. Once restarting the network manager, I got a window popping in saying internet was disconnected. Service manager is running active. Unfortunately I cannot connect to the internet still.. – user678722 Jun 3 '18 at 8:01
  • Do ls -la ~/.bash_history lets see the ownership and paste it into your question not into another answer! – George Udosen Jun 9 '18 at 7:22
0

First of all, you need to check whether the network-manager is running fine or not? Please use the below command and see the status.

service network-manager status

If everything is fine, it should show running(active) status, otherwise, you may see some error here.

If the network-manager is not running, try to restart the network-manager using the below command:

service network-manager restart

(You may need sudo access to run this command.)

5
  • @user678722 Can you please post the last 100 lines of dmesg while restarting the network. First restart the network-manager using the command above and then run the below command to get the last 100 lines. dmesg | tail -n 100 and post the output by editing your question. Also, post the last 100 lines of /var/log/messages just after restarting the network-manager – Samit Jun 4 '18 at 8:14
  • Dear Samit, thank you for your help. Please find the requested code below. – user678722 Jun 9 '18 at 7:03
  • Please use the steps of this link and reboot the system. askubuntu.com/questions/792041/… Let me know the output – Samit Jun 10 '18 at 7:55
  • Dear Samit, I am truly thankful for your help as the internet is now fully running! Truly appreciated! I had to reboot the laptop a number of times and then it finally worked. Thank you! – user678722 Jun 10 '18 at 17:57
  • Glad to know that the issue is fixed now. Please accept the answer if this really worked for you. – Samit Jun 11 '18 at 7:42
0

Thank you for your answer. I followed your advice yesterday and the network manager was indeed running (active). There was a line of code stating a "fail" when I ran the "nework-manager status" command: "failed to enumerate oFono devices: GDBUS.Error:org.freedesktop.DBus.Error.Serv

Not sure if this will bring any clarity for the outstanding issue, but hope it can help as the computer states the wireless connection being "out of range". I did try to enable the Wifi through a slide button, but the system did not allow me to do this.

Unfortunately, I am really lost on how to resolve this. I'll be appreciated for any further suggestion/advice. Thank you.

3
  • When an error occurs always read your logs with dmesg | tail -20 or journalctl --follow, Then add grep for specifics or egret for a range to narrow down your issue, as in journalctl --follow | egrep "error|corrupt|missing" – user610658 Jun 2 '18 at 6:49
  • Run sudo gdbus introspect --system --dest org.freedesktop.UDisks --object -path /org/freedesktop/UDisks/devices/sda to find out what the gdbus initially stands for – user610658 Jun 2 '18 at 7:03
  • Used command above. The result was "gdbus COMMAND --help". Tried dmesg command as well but not sure what to look for as I am not savy at all with coding. I will appreciate any further advice on how to resolve this. – user678722 Jun 3 '18 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.