1

I recently, for fun, tried to take an old computer, format it, and install a dual OS (Windows 10 Home and Ubuntu 18.04) I successfully got both of them installed and running, but to switch between them, I have to use the device's boot selector instead of Ubuntu's convenient grub interface. It does show, but not on boot-up. See the image below for the exact boot order.

boot manager diagram
(Click image to enlarge)

No matter what I do, I can't get it to show grub on boot-up. I've tried changing the EFI within Ubuntu (it resets after restart), changing within Windows (no option), changing from BIOS (no option), reinstalling grub like 3 times (no effect) and everything else. Can someone please help me get grub to show on first startup?

Here is the output of sudo parted -l :

Model: ATA ST750LM022 HN-M7 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 
Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  524MB  523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32           EFI system partition          boot, esp
 3      629MB   646MB  16.8MB                  Microsoft reserved partition  msftres
 4      646MB   393GB  393GB   ntfs            Basic data partition          msftdata
 5      393GB   744GB  351GB   ext4
 6      744GB   750GB  6328MB  linux-swap(v1)

I checked, both Windows 10 and Ubuntu 18.04 are in UEFI.

  • 1
    Are both installed in same boot mode, or both UEFI? And is Windows fast start up off, so grub2's os-prober can see the Windows install? then all you should need is sudo update-grub and then when grub has both entries it will automatically show. askubuntu.com/questions/843153/… If not post this link to details: help.ubuntu.com/community/Boot-Info – oldfred May 29 '18 at 3:27
  • I did turn off fast boot. I forgot to mention it, but I tried everything I physically could. I'll try that command tomorrow, I need sleep. – Hexbugman213 May 29 '18 at 6:47
  • I think you need to also disable hibernate, then re-enable ubuntu as the default uefi boot. Otherwise when windows tries to hibernate, it will change the uefi settings. – pim May 29 '18 at 14:19
  • Please boot into Ubuntu and edit your post with the output of sudo parted -l – Elder Geek May 29 '18 at 15:15
  • pim, When i disabled hibernate it didn't even give me an option for fast boot, so i assumed it was disabled automatically. – Hexbugman213 May 29 '18 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.