1

Today I upgraded Ubuntu from 17.10 to 18.04 and can't figure out what's going on. When I click suspend button display becomes black but laptop is still running. I already tried many things like editing logind.conf and acpi-support files but nothing same old same old. Help me

  • Sometimes you can suspend via menu, when it doesn't work by closing lid. You can look for messages using journalctl -b | grep sleep and journalctl -b | grep suspend. Linux is infamous for suspend/resume problems and with laptops in general. Still for all it's warts it beats Windows amongst enthusiasts albiet not for business and finance. – WinEunuuchs2Unix May 28 '18 at 22:58
2

I've been experiencing what appears to be this very same issue with an HP Pavilion 11 x360.

I have installed Ubuntu and Kubuntu 18.04 a couple of times on my friend's and my own laptops without any suspend issues, but this one 'problem child' has been very much misbehaving.

The Pavilion goes to a black screen but the power LED stays on and the fan continues to spin (if it had been doing so already). The laptop remains unresponsive to anything until I shut it down.

It has done this with both Ubuntu and Kubuntu 18.04 but worked fine with Ubuntu and Kubuntu 17.10.


Edit - There are a few issues that look similar - an nVidia graphics driver problem, the machine going into s2idle instead of suspend and this specific issue that seems to only be affecting a small number of people. Take a look at the steps here to help identify your issue: Ubuntu 18.04 - Dell XPS13 9370 no longer suspends on lid close


It doesn't seem to be affecting everyone (otherwise I assume it'd be all over the forums by now) but after trying things like pm-utils and adjusting grub configurations to no avail, I found this answer from matalak's question:

Ubuntu 18.04 crashes on resuming from suspend

Following the suggestion, I used UKUU to install an older kernel (4.14.47 - the most up to date 4.14 kernel) and suspend worked again as it should.


Edit - If you have nVidia graphics, there seems to be a fix that is working for a number of people, helpfully provided by cascagrossa in the answer to the question linked above.

A bug report has been opened https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1774950 and there is a patch that resolves the issue, so the suspend problem should be fixed in an update in the near future.


Using an older kernel is only a temporary solution and I'd quite like to be using 4.15 and onwards (4.16 and 4.17 and had the same suspend problems when i tried them out)..

Could you also add what machine you are using to your question?

Can you let us know if trying the 4.14 kernel lets suspend work as normal for you too?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.