I must be missing something obvious. I've taken over the development of a customised Ubuntu installation, which uses the 11.04 Desktop Live ISO with a customised preseed file to make the installation of a new PC completely automatic - build the ISO with the UCK tools, burn it to a DVD, boot a PC from the DVD, go for a nice cup of tea, and come back to a finished installation just waiting for you to click to reboot into the new system.

It all works fine except for this: I cannot get a late_command in the preseed file to run. Everything else in the file works fine - partitioning, choosing packages, creating a user, etc - but the last line of the preseed file:

d-i preseed/late_command string /bin/echo "trying echo" > /var/log/myfile

...doesn't happen. I've tried every possible combination of in-target and prefixing /target/ to my paths. I've SSHed to the machine while the automated installation is running and verified that my output paths exist and are writable. I've checked the kernel command line to make sure the right preseed file is being used. My late_command command just sits there, refusing to be run. We've been sitting here staring at each other, for quite some time now. My brain has started dribbling out my ears, and I've just plain started dribbling.

Is there some crucial piece of ancient Oriental preseed-fu I'm missing? I'm at my wits' end here (and my mum will tell you I didn't have far to go) - any help will be most appreciated.


If you're using the desktop installer (aka Ubiquity), you may try putting your late_command under

ubiquity ubiquity/success_command string


ubiquity ubiquity/success_command string /bin/echo "trying echo" > /var/log/myfile

I usually put both this and the d-i stanza, just to make sure my preseed file works on both.

  • I hadn't realised there was more than one process that might be using the preseed file. How can I tell which one gets run? – Tim Feb 15 '12 at 8:23
  • Hurrah, the ubiquity command worked - thanks! I'll mark yours as the answer even though the late_command failure is still a mystery. – Tim Feb 16 '12 at 8:52
  • A long time later, but for anyone finding this thread from Google - Ubiquity uses the Debian-Installer syntax (d-i) but only a subset of the commands, which is quite poorly documented even as of 2017. Even better, it silently ignores the ones that don't apply, so it's difficult to know which ones it's actually using. – Gargravarr Dec 29 '17 at 14:02

The right one string is

ubiquity ubiquity/success_command string in-target /bin/echo "trying echo" > /target/var/log/myfile

  • Should this meant to be a comment on the accepted answer? – Eric Carvalho Sep 3 '15 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.