3

I am having trouble when shutting down Dell Alienware Aurora R7 after installing ubuntu 18.04. The nvidia drivers were successfully installed.

enter image description here

3
  • 1
    I faced the same issue myself and found a solution. See my answer here for the instructions: unix.stackexchange.com/a/446913/52937
    – Yurij
    May 30, 2018 at 13:30
  • @yttrium Could you copy-paste your answer from U&L to AU as the question might be closed because it's a bug... (Already upvoted over there, will do same here if you ping me) ;-)
    – Fabby
    Oct 24, 2018 at 21:22
  • @Fabby copy-pasted.
    – Yurij
    Oct 25, 2018 at 8:22

1 Answer 1

6

Copy-pasting answer from U&L as per people request

After reading kernel sources, I found a function we need to blacklist!

Thanks to Stephen Kitt for the hint about initcall_blacklist.

Add initcall_blacklist=dw_i2c_init_driver to the kernel command line. This works for me on kernel 4.15.0.

For anyone else who'll find this answer. You can do it by editing /etc/default/grub:

  1. Run in the terminal: sudo -H gedit /etc/default/grub.
  2. Append blacklist string to the GRUB_CMDLINE_LINUX_DEFAULT: GRUB_CMDLINE_LINUX_DEFAULT="… initcall_blacklist=dw_i2c_init_driver".
  3. Save the file, close the editor.
  4. Run in the terminal: sudo update-grub.
  5. Reboot and test!
4
  • 1
    And upvoted as promised! :-)
    – Fabby
    Oct 25, 2018 at 18:02
  • thank you so much @yttrium. it worked perfectly
    – prasadith
    Oct 27, 2018 at 22:03
  • I am using a Dell Aurora R7 w/ a Nvidia 1070Ti. I am running Kubuntu 18.04.2 on the 4.18.0 kernel and this worked for me.
    – user838494
    Mar 23, 2019 at 15:41
  • Also on a Dell Aurora R7 and this resolved the issue! Thanks a ton stephen-kitt!
    – Brooks B
    Jul 15, 2021 at 4:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.