1

My goal is to install Kubuntu in English language in Belgium.

Ok, let's start from installation.

Choose Belgian keyboard.

screenshot

Region: Europe, Time zone: Belgium.

screenshot

The installation is done. This is the first login screen. But... Why is it telling me the time in German?

screenshot

Let's try fixing it and set everything in Belgium English!

screenshot

After a reboot is the time still in German.

screenshot

When I run sudo apt upgrade. A nasty locale error passes by.

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_TIME = "en_BE.UTF-8",
        LC_MONETARY = "en_BE.UTF-8",
        LC_ADDRESS = "de_BE.UTF-8",
        LC_TELEPHONE = "de_BE.UTF-8",
        LC_NAME = "de_BE.UTF-8",
        LC_MEASUREMENT = "en_BE.UTF-8",
        LC_IDENTIFICATION = "de_BE.UTF-8",
        LC_NUMERIC = "en_BE.UTF-8",
        LC_PAPER = "de_BE.UTF-8",
        LANG = "en_BE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

sudo locale-gen en_BE outputs Error: 'en_BE' is not a supported language or locale

Why is it doing this and is it fixable?

user@user-virtual-machine:~$ cat /etc/default/locale
#  File generated by update-locale
LANG="en_US.UTF-8"
LC_NUMERIC="de_BE.UTF-8"
LC_TIME="de_BE.UTF-8"
LC_MONETARY="de_BE.UTF-8"
LC_PAPER="de_BE.UTF-8"
LC_NAME="de_BE.UTF-8"
LC_ADDRESS="de_BE.UTF-8"
LC_TELEPHONE="de_BE.UTF-8"
LC_MEASUREMENT="de_BE.UTF-8"
LC_IDENTIFICATION="de_BE.UTF-8"


user@user-virtual-machine:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_BE.UTF-8
LANGUAGE=
LC_CTYPE="en_BE.UTF-8"
LC_NUMERIC=en_BE.UTF-8
LC_TIME=en_BE.UTF-8
LC_COLLATE="en_BE.UTF-8"
LC_MONETARY=en_BE.UTF-8
LC_MESSAGES="en_BE.UTF-8"
LC_PAPER=de_BE.UTF-8
LC_NAME=de_BE.UTF-8
LC_ADDRESS=de_BE.UTF-8
LC_TELEPHONE=de_BE.UTF-8
LC_MEASUREMENT=en_BE.UTF-8
LC_IDENTIFICATION=de_BE.UTF-8
LC_ALL=
3
  • 1
    The problem is that no en_BE locale exists in glibc, which provides the locales in Ubuntu (including Kubuntu). – Gunnar Hjalmarsson May 28 '18 at 19:38
  • Can you please edit your question and show us the output of these two commands: 1. cat /etc/default/locale 2. locale – Gunnar Hjalmarsson May 28 '18 at 19:44
  • Here you go, thank you for your time! @GunnarHjalmarsson – MatMis May 28 '18 at 19:50
2

I'm not using Kubuntu, and am not too familiar with the KDE way to handle languages and locales.

However, given the information above, one way to (almost) achieve the desired behavior is to pretend that you are Danish. :)

So my suggestion is that you change the overall Region setting to Denmark - English. That will give you ISO compatible date and time formats.

Then you may want to change the Currency setting to Belgium - German to get the Belgium currency symbol.

Those changes won't affect the login screen, though. To fix the login screen you can open the /etc/default/locale file for editing, remove all the settings of LC_* variables, and only keep the setting of LANG.

HTH

4
  • This works, but when I run locale I says: Cannot set LC_ALL to default locale: No such file or directory. link Also, should I still set currency to Belgium - German when my native language is Belgium Flemish? So is your suggestion to set everything except the region (most upper) setting to Belgium - German? – MatMis May 28 '18 at 20:39
  • Oh, you probably mean to set it to 'No change'. Then the error is gone! Thanks! – MatMis May 28 '18 at 20:47
  • This works – MatMis May 28 '18 at 20:56
  • @MatMis: Right, that's what I meant. Glad to hear that it solved the problem for you. (Personally I consider the KDE GUI buggy, since it lets you set language/country combinations which are not represented by existing locales.) – Gunnar Hjalmarsson May 28 '18 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.