3

I have a thinkpad X270 with a dual boot win10 / Ubuntu 16.04. Here is the output of fdisk -l:

Disk /dev/loop0: 86,6 MiB, 90828800 bytes, 177400 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 86,6 MiB, 90812416 bytes, 177368 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 162,6 MiB, 170479616 bytes, 332968 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 162,1 MiB, 169943040 bytes, 331920 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop4: 159,5 MiB, 167231488 bytes, 326624 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop5: 86,6 MiB, 90759168 bytes, 177264 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/nvme0n1: 477 GiB, 512110190592 bytes, 1000215216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: DAC31813-E9D7-4C23-A2BF-993BFA742FA8

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      2048     534527    532480   260M EFI System
/dev/nvme0n1p2    534528     567295     32768    16M Microsoft reserved
/dev/nvme0n1p3    567296  547606527 547039232 260,9G Microsoft basic data
/dev/nvme0n1p4 998166528 1000214527   2048000  1000M Windows recovery environmen
/dev/nvme0n1p5 547606528  965101567 417495040 199,1G Linux filesystem
/dev/nvme0n1p6 965101568  998166527  33064960  15,8G Linux swap

Partition table entries are not in disk order.

So I suspect that my windows partition is /dev/nvme0n1p3, correct?

Now, here is my problem, when I try to mount this partition with:

sudo mount /dev/nvme0n1p3 /media/myusername/windows

I get the following error message:

mount: wrong fs type, bad option, bad superblock on /dev/nvme0n1p3,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so. 

Do you have any idea what the problem might be? dmesg | tail does not seem to contain any useful hint.

EDIT

In addition, as asked by @david-foerster, here is the output of sudo lsblk -f

NAME        FSTYPE  LABEL     UUID                                  MOUNTPOINT
loop1       squashf                                                /snap/spotify
loop4       squashf                                                /snap/spotify
loop2       squashf                                                /snap/core/44
loop0       squashf                                                /snap/core/45
nvme0n1                                                            
├─nvme0n1p5 ext4              b82c7e09-ca99-4d36-a414-e27dad39ee2a /
├─nvme0n1p3                                                        
├─nvme0n1p1 vfat    SYSTEM    E274-CF83                            /boot/efi
├─nvme0n1p6 swap              6fea09e6-54ab-49b5-a792-24c14a3fc1af [SWAP]
├─nvme0n1p4 ntfs    WinRE_DRV 3C3477E53477A116                     
└─nvme0n1p2                                                        
loop5       squashf                                                /snap/spotify
loop3       squashf                                                /snap/core/46
7
  • 1
    can you try to run chkdsk /f from windows and then try sudo mount -t ntfs /dev/nvme0n1p3 /media/myusername/windows . Commented May 28, 2018 at 20:16
  • 1
    I went to windows, I ran chkdsk /f and rebooted twice in windows, but sudo mount -t ntfs /dev/nvme0n1p3 /media/myusername/windows is still giving the same error: The device '/dev/nvme0n1p3' doesn't seem to have a valid NTFS
    – guigux
    Commented May 28, 2018 at 20:50
  • I also tried to use the disk name nvme0n1 instead of the partition name nvme0n1p3. I get the same error.
    – guigux
    Commented May 28, 2018 at 20:52
  • Is there another, stronger windows utility, to fix NTFS disks? (My windows partition works correcly, though).
    – guigux
    Commented May 28, 2018 at 20:57
  • 1
    Have you installed ntfs-3g in ubuntu? Commented May 28, 2018 at 20:58

4 Answers 4

3

Try this:

sudo mount -t ntfs /dev/nvme0n1p3 /media/myusername/windows

System doesn't identify the filesystem type. So you have to enter that as ntfs. If it fails to mount Windows partition as read/write mode you have to disable fast boot mode from Windows. You can follow this guide to disable it. If you need a gui way to mount and mount at startup see this question's first answer. If still doesn't work, your PBR (Primary Boot Sector) may have corrupted. Try to run chkdsk /f from windows and try to mount it again.

Edit: Your partition name doesn't look like sdaxx because youre machine may use SSD instead of HDD hard drive.

3
  • Thanks, here is what I get when I follow your suggestion. I think you re right, filetype is not identified correcly: NTFS signature is missing. Failed to mount '/dev/nvme0n1p3': Invalid argument The device '/dev/nvme0n1p3' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
    – guigux
    Commented May 28, 2018 at 19:45
  • 1
    fast boot mode is already disabled...
    – guigux
    Commented May 28, 2018 at 19:48
  • PCI express drives are NVMe ... And so named nmveNxPx
    – cmak.fr
    Commented May 28, 2018 at 19:48
0

Yes /dev/nvme0n1p3 seems to be the main Windows partition

Disks named like this (nvme...) are connected to the pci-express bus. Your laptop seems to run with a pci ssd drive.

Nautilus (the Ubuntu file browser) should be able to mount the Windows drives.

(Ok, you have disabled the Windows fast Startup feature)

Did you try to run (with Win10) chkdsk against your Windows drives ?

I had encounter the same issue solved by this

0

Rather than having to remember the FS type you can use the auto parameter when mounting:

mount -t auto /dev/nvme0n1p3 /media/myusername/windows

Remember in order to mount you have to create the directory first, ie:

mkdir -p /media/myusername/windows
  • The -p or --parents switch means:

    no error if existing, make parent directories as needed

0

I've been having this problem as well. This solved it for me. Turns out it was because my Windows partition was BitLocker encrypted. Use (Windows) BitLocker-encrypted drive on Ubuntu 14.04 LTS

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .