1

Problem

For the last year or so I've had constant issues with the wireless on my laptop. Network drops randomly every 5-10 minutes at home, while away from home I sometimes can't connect at all.

I've looked up countless AskUbuntu questions, forum posts, bug tracker reports, etc - to no avail.

Previously the icon in the status bar showed up-and-down arrows instead of the appropriate wifi icon - whether internet was working or not. When internet went down there was NO indication in the status bar or elsewhere. The laptop thought it was still online but no websites would load and no services would work.

After upgrading to 18.04 it now gives me a pop-up error when internet fails: "Activation of network connection failed"

There are two potentially relevant messages in dmesg:

  1. wlp1s0: deauthenticating from 44:e1:37:2f:e5:40 by local choice (Reason: 3=DEAUTH_LEAVING)
  2. wlp1s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22)

I'm currently posting from my phone because I don't have access to wired internet and my laptop isn't connecting at all. So it may take some time to type up responses to comments and answers.

Update: Upon getting home I tested my home wifi and I was able to connect without error, so it's not like the wireless card has gone out on me. Home network: Connects fine, but loses internet every 3-5 minutes. Phone HotSpot: Doesn't connect ("Activation of network connection failed")

Environment

  • I have a Dell Latitude E5570. It did not come with Ubuntu. Ubuntu 16.04 was installed cleanly from a bootable USB after formatting the drive
  • sudo lshw -class network shows I have an Intel Corporation Wireless 8620 Wireless Interface (rev 3a)
  • The same command shows my driver is iwlwifi
  • I'm currently running Ubuntu 18.04 (among the many things I tried to fix my internet, upgrading Ubuntu was one of them)
  • ls -l /lib/firmware/iwlwifi-8000C-* shows I have firmware versions 13 through 34. dmesg | grep iwlwifi confirms I'm loading firmware version 34.0.1
  • I'm running NetworkManager version 1.10.6
  • I don't believe my wireless hardware is damaged because I can see a list of publicly broadcast SSIDs. When enabling my phone's hotspot it immediately shows up as an option. I just cant connect when I select the desired network.

What I've tried

  1. Create /etc/pm/config.d/config and add the line SUSPEND_MODULES="iwlwifi wlp1s0"
  2. Create /etc/modprobe.d/iwlwifi.conf and add the line options iwlwifi fwlps=N
  3. sudo modprobe -r hp_wmi
  4. Edit /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and change 3 to 2
  5. Update linux-headers
  6. Upgrade to Ubuntu 18.04
  7. Turn off the laptop, unplug the battery, wait 10 minutes, plug everything back up
  8. Disable wifi security
  9. Connect to 2.4GHz or 5GHz
  10. Edit /etc/modprobe.d/iwlwifi.conf and set 11n_disable= to either 1 or 8
  11. Uninstall Docker and Vagrant
  12. Edit /etc/default/crda and set REGDOMAIN=US

I probably tried a lot of other things that I just can't recall at the moment. I'm still having trouble and it's infinitely frustrating.

  • did you try to stop networkmanager service and connect manually by using iwconfig and ifconfig – cmak.fr May 28 '18 at 21:23
  • @cmak.fr just spent a long time trying to connect via iwconfig and getting constant errors when I google'd it and found iwconfig doesn't support WPA. I tried wpa_supplicant but got the error: "Could not set interface wlp1s0 flags (UP): Operation not permitted" – stevendesu May 29 '18 at 14:10
0

What Worked

I previously avoided using alternate network managers because in all of my research and testing I found multiple blog posts and AskUbuntu answers claiming that WICD hasn't been updated since 2012, that NetworkManager has been better since 16.04, that many tools for network management don't support multiple networks (making them useless for a laptop that moves from place to place), etc

I ultimately decided to give it a chance. Step-by-step (for anyone having a similar issue and following along):

  1. I opened Ubuntu Software and searched for "Synaptic" -- basically a superior version of Ubuntu Software. I installed this
  2. Using Synaptic I searched for and installed "wicd". Upon selecting wicd it auto-selected several other packages. I didn't bother changing any defaults
  3. I rebooted my computer
  4. I hit the Windows key to open the app launcher, and searched for "wicd" and launched it
  5. I selected and connected to my phone's hot spot (which worked this time) -- it doesn't need to be a phone's hot spot, though. Any wireless network will work
  6. Now connected to the internet, I used Synaptic to uninstall network-manager
  7. I rebooted my computer once more

At the very least I was able to connect to my phone's hot spot, so I think things are looking up. I'll connect to my home network and see if I can stay online all day without losing internet.

Caveat

Using Wicd caused all of my connection and stability issues to go away entirely. Now once I'm online, I stay online all day. I can also now connect to my phone's hotspot. However, it now takes 2-3 minutes to initially connect when I wake my computer from sleep or first turn it on. This isn't the end of the world, but it can be a bit annoying.

  • Did it work? can you confirm? I'm having the same crappy issues with wireless... Very unstable and heavily affects my productivity. Like I'd be on a roll, then BAM! no internet. I spend like 5 minutes restarting network manager by issuing a sudo systemctl restart NetworkManager command. Sometimes it works, sometimes, it doesn't. It's frustrating. – rvdavid Jul 15 '18 at 13:05
  • 1
    @rvdavid All of my stability issues are gone now (once I'm online I remain online all day with zero problems), although it now takes about 2-3 minutes for the internet to start working when I wake my laptop from sleep or restart it. It's worlds better than it was, but it's a bit annoying when I pick up my laptop to look something up, flip open the lid, and I'm met with "No internet connection" for several minutes while I repeatedly mash refresh on Google. – stevendesu Jul 16 '18 at 14:31
  • Thank you for getting back to me. In my quest for stability, I've updated the kernel to 4.17.5 via ukuu. Seems to be now be stable. I can flip my laptop open and all that and it works. If it becomes unstable again, I'll try wicd. Thanks again – rvdavid Jul 18 '18 at 0:38
  • @rvdavid I just checked and I'm on 4.15.0, myself. I'll try updating to 4.17.5 and see if it will allow me to switch back from wicd to NetworkManager, because the 2-3 minute startup is a bit annoying. – stevendesu Jul 20 '18 at 4:12
  • 2 weeks later. Still experiencing intermittent disconnections. Something wrong with the atheros driver. I was doing a presentation yesterday and it cuts out right in the middle. I had to do some fast thinking and USB tethered which worked for the rest of the way. – rvdavid Aug 2 '18 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.