0

how can i reset this setting

How can I reset this setting for opening file to default or to unspecified?

This problem affects both firefox and firefox-trunc installed in Ubuntu.

UPDATE: append screenshots 1) Can't choose other Helpers apps but shown on 2) in Mozilla->Prefs->Applications i'dont see any app for bin but the default program for openning is libreoffice enter image description here

enter image description here

  • 1
    can you select "ask" from the dropdown and then check the "do this automagically" box? – Joshua Besneatte May 28 '18 at 15:36
2

Option One - Via Firefox

In Firefox -> Preferences -> General -> Applications:

You can set "bin" to be "always ask"

Firefox Preferences

Option Two - Nuke Your MimeTypes File

This will reset all of your file associations.

rm ~/.mozilla/firefox/(unique id).default/mimeTypes.rdf

You will need to replace (unique id) with whatever yours is named.

Option Three - Edit Your MimeTypes File

nano ~/.mozilla/firefox/(unique id).default/mimeTypes.rdf

Look for the part about "bin" and you can change it to something like this:

  <RDF:Description RDF:about="urn:scheme:bin"
                   NC:alwaysAsk="true">
    <NC:handlerProp RDF:resource="urn:scheme:handler:bin"/>
  </RDF:Description>

Notice the "alwaysAsk=true" part... this is what will need to be changed in your file

| improve this answer | |
  • 1
    as advised by kb.mozillazine i deleted rm -rf mimeTypes.rdf and then choose new app handler for archives as archive manager. and from now i 'm having "archive manager" just like libreoffice it cover all unknown types as default down-loader. In short words problem persist the Firefox does not ask for unknown types, but substitute a selected – Yurij May 29 '18 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.