1

I'm using Ubuntu 16.04 lts. One day I fired it up and after boot only the desktop appeared, no nautilus. The only gui functions I have been able to access are the ones on the desktop. I opened a terminal tried to launch nautilus from there, I received

Failed to connect to Mir: Failed to connect to server socket: No such file or directory     
Unable to init server: Could not connect: Connection refused
(Nautilus:3753): Gtk-WARNING **: cannot open display:

When I try to open apps like Libreoffice from terminal I also get

cannot open display

I have no idea what happened or what to do. I have tried several Mir fixes, still same problem exists.

EDIT: After days of trying various solutions, I was able to get unity and nautilus back. After three boots, the problem returned. I restarted in recovery mode and used the dpkg tool to fix dependencies, and it came back, for now. That suggests to me that some update created the problem in the first place. I don't know that the issue is 'fixed,' but everything is working ... for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.