9

I newly installed eclipse form official Ubuntu repositories (sudo apt install eclipse). When I run it from launcher or terminal it doesn't start and show this error massage

An error has occurred. See the log file

and the log file content is :

!SESSION Mon May 28 17:52:17 IRDT 2018 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-05-28 17:52:18.099
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
$ dpkg --status eclipse
Package: eclipse
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 99
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: all
Version: 3.8.1-11
Depends: eclipse-jdt (>= 3.8.1-11), eclipse-pde (>= 3.8.1-11)
Description: Extensible Tool Platform and Java IDE
 The Eclipse Platform is an open and extensible platform for anything and yet
 nothing in particular. It provides a foundation for constructing and running
 integrated software-development tools. The Eclipse Platform allows tool
 builders to independently develop tools that integrate with other people's
 tools so seamlessly you can't tell where one tool ends and another starts.
 .
 This package provides the whole Eclipse SDK that contains Eclipse Platform,
 Java development tools and Plug-in Development Environment, including source
 and both user and programmer documentation.
Original-Maintainer: Debian Orbital Alignment Team <pkg-java-maintainers@lists.alioth.debian.org>
Homepage: http://www.eclipse.org/

$ apt-cache policy eclipse
eclipse:
  Installed: 3.8.1-11
  Candidate: 3.8.1-11
  Version table:
 *** 3.8.1-11 500
        500 http://ir.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://ir.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

It does not give any other errors or warnings. I am on Xubuntu 18.04.

  • 1
    Could you please add a little more detail? What exactly did you do to install and then run Eclipse, what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster May 28 '18 at 14:05
  • @DavidFoerster Thanks for your comment. I just edit question. Hope it's clear know. – parsa2820 May 28 '18 at 15:24
  • 1
    That was helpful. Could you please edit your question to include the output of apt-cache policy eclipse and dpkg --status eclipse? Thanks. – David Foerster May 28 '18 at 16:37
  • @DavidFoerster edited. – parsa2820 May 28 '18 at 17:38
  • So far so good. Did you ever install other Eclipse bundles on this Ubuntu installation? Could you please also add the output of which -a eclipse and grep -iFe eclipse -R --include='*.desktop' /usr/share/applications /usr/local/share/applications ~/.local/share/applications as well as the content of /usr/lib/eclipse/configuration/config.ini? – David Foerster May 28 '18 at 17:48
1

I was getting this error:

$ sudo snap install eclipse --classic  
error: snap "eclipse" has "install-snap" change in progress

Tried for long to resolve it and finally this worked out for me:

Run command:

$ snap changes

and check if its output says "Doing", something like this:

ID   Status  Spawn               Ready  Summary
92   Doing   today at 15:17 IST  -      Install "eclipse" snap

If yes, you can just abort this by using command :

sudo snap abort 92

where, 92 is ID.

Then, if you run install command again, it works fine.

sudo snap install eclipse --classic

Hope this helps someone.

3

I recommend for greater ease and comfort:

sudo apt --remove purge eclipse

or

sudo apt --remove purge netbeans

and install form SNAP:

sudo snap install eclipse --classic

or

sudo snap install netbeans --classic

2

I recommend installing the Eclipse snap package which is also more up-to-date (Eclipse IDE for Java Developers version 4.7.3):

sudo snap install eclipse --classic  

You can install snap packages alongside apt packages in order to try them, and afterwards remove the Eclipse apt package if you like the snap package better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.