1

Rest Assured this isn't a duplicate.
I was running a dual boot setup (Windows + kde Neon in UEFI mode). Had to reinstall windows 10. Since then lost my access to KDE neon. Boots directly to windows. Tried deleting the Linux partition and reinstalling. But no use. I looked around a lot and one solution was using OS-Prober. I found the two partitions.

/dev/sda1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi /dev/sda7:KDE neon LTS User Edition 5.12 (16.04):neon:linux

and tried running

$ sudo os-prober
Result :
/dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi /dev/sda7:KDE neon LTS User Edition 5.12 (16.04):neon:linux
then :

$ sudo update-grub
/usr/sbin/grub-probe: error: failed to get canonical path of `aufs'.

Tried Boot Repair.

Here is The log.
http://paste.ubuntu.com/p/RkT6Hfh5Y8/

P.S : have tried running this on cmd windows, no use

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

closed as off-topic by DK Bose, Bruni, karel, Eric Carvalho, Fabby May 30 '18 at 21:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – DK Bose, Bruni, karel, Eric Carvalho, Fabby
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    KDE Neon isn't supported here because, even though it uses Ubuntu as its base, it isn't an official flavor. Try at unix.stackexchange.com. – DK Bose May 28 '18 at 12:43
  • I understand but can you please try to help me out here. I'm sure the problem is independent of the distro. – Ajith Shenoy May 28 '18 at 14:40
  • You could try asking at kubuntuforums.net where quite a few devs and Neon users are present. – DK Bose May 28 '18 at 14:43