0

I had one (Ubuntu) partition with /home and everything else. I wanted to separate my /home onto a new partition, but due to the size of it compared to the rest of the data, I tried to move my / to a new partition instead. I followed a combination of how-to's, since I couldn't find one describing exactly what I wanted to do, specifically the official Ubuntu moving an entire partition tutorial and the How-To Geek on creating a separate /home partition.

As far as I can tell, the only part I can't figure out is how to update the MBR, Step 6 on the Ubuntu tutorial. I think the issue might be because I still need to mount my old / partition at startup (because it still will be my /home partition). The specific setup I need to do in the Disks program is unclear. The first thing I tried didn't change anything. The second try, my old partition was booted, but it couldn't find the home folder.

What selections should I make in the Disks program and/or what else should I do to fix this? How can I change the MBR to boot a different partition, while still keeping the old partition auto-mounted (assuming that is necessary)?

Edit: Output from sudo parted -l:

Model: ATA WDC WD10S21X-24R (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  1050MB  1049MB  ntfs            Basic data partition          hidden, diag
 2      1050MB  1322MB  273MB   fat32           EFI system partition          boot, hidden, esp
 3      1322MB  2371MB  1049MB  fat32           Basic data partition          hidden
 4      2371MB  2505MB  134MB                   Microsoft reserved partition  msftres
 5      2505MB  163GB   160GB   ntfs            Basic data partition          msftdata
 8      163GB   816GB   653GB   ext4            Ubuntu Home
11      816GB   858GB   41.9GB  ext4            Ubuntu Boot
10      858GB   942GB   83.9GB  ntfs            Windows Storage               msftdata
 9      942GB   959GB   17.1GB  linux-swap(v1)
 6      959GB   986GB   26.8GB  ntfs            Basic data partition          msftdata
 7      986GB   1000GB  14.6GB  ntfs            Basic data partition          hidden, diag

My current full partition is "Ubuntu Home" and my goal is to make it only the /home folder, with "Ubuntu Boot" being the OS partition.

Edit: lsblk output:

NAME    MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda       8:0    0 931.5G  0 disk 
├─sda4    8:4    0   128M  0 part 
├─sda2    8:2    0   260M  0 part /boot/efi
├─sda9    8:9    0  15.9G  0 part [SWAP]
├─sda7    8:7    0  13.6G  0 part 
├─sda10   8:10   0  78.1G  0 part 
├─sda5    8:5    0 149.4G  0 part 
├─sda3    8:3    0  1000M  0 part 
├─sda1    8:1    0  1000M  0 part 
├─sda8    8:8    0 608.1G  0 part /
├─sda11   8:11   0  39.1G  0 part 
└─sda6    8:6    0    25G  0 part 
9
  • Can you run sudo parted -l so that we can have a look at your partition setup? – Paul Benson May 28 '18 at 7:30
  • @PaulBenson Added it. – Prime624 May 28 '18 at 16:09
  • Run lsblk. Can you confirm the mount point for sda8, and also sda11? The latter partition seems unnecessary as you already have the proper boot partition installed on sda2. You can't update the MBR as you don't have one. Your disk is a GPT format. – Paul Benson May 28 '18 at 16:56
  • 1
    Like I said you have a GPT disk with a UEFI BIOS. MBR has largely been replaced by GPT. Most BIOS now work with UEFI systems, not MBR, although there is still a legacy MBR option available for many BIOS if you require it. Have a read about ESP which is your sda2 partition. – Paul Benson May 28 '18 at 19:06
  • 1
    I have multiple installs of Ubuntu and every time I reinstall, I have to restore the /boot/efi/EFI/ubuntu/grub.cfg. Sometimes I just copy back the backed up copy (I quickly learned to backup the ESP), but now often just edit it to have new UUID & drive/partition info. askubuntu.com/questions/738132/… – oldfred May 28 '18 at 20:47
0

Tl;dr, my issue was that the Ubuntu instructions assumed I had MBR, which I did not. I had GPT/EFI, as @PaulBenson pointed out.

I was able to edit the UUID and partition in this file /boot/efi/EFI/ubuntu/grub.cfg which allowed me to boot from the new root partition. After that, I still could not log in, because it thought that my entire home partition was /home, when in fact, it was an entire system, including /home. So I went into TTY1 and deleted the old OS files (risky, I know) and moved my home folder(s) from /home/{username} to /{username} on my /home partition. Rebooted and it works. This is assuming that all the correct links and auto-mounts are set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.