I am getting a kernel panic "not syncing: VFS: unable to mount root fs on unknown-block(0,0)" with kernel 4.13.0-43 on Ubuntu 17.10. I can boot just fine with 4.13.0-41. After a successful boot using 4.13.0-41 I can get 4.13.0-43 to boot if I boot in text mode and remove the quiet and splash options. Anyone have any ideas as to what is happening? My disk drive is a 250Gb disk with one partition (I accepted the default options when I installed the system).

  • Start the Disks application and take a look at the SMART Data & Tests. – heynnema May 27 '18 at 23:52
  • I checked the SMART status of the disk and it passed. I just ran the latest updates and a new version of util-linux was installed. I have rebooted the laptop 5 or 6 times now using the 4.13.0-43 version of the kernel. The problem started last week after the unattended upgrades ran. I am going to keep my eye on this for a while. Perhaps the patch to util-linux solved the issue. – sunflowerastro May 28 '18 at 9:45
  • please see my answer for more procedure... – heynnema May 28 '18 at 12:47
  • I ran the file system checker as suggested and no errors were found. My system is getting the same error again after about 10 successful reboots. – sunflowerastro May 28 '18 at 13:20
  • please see the update to my answer... – heynnema May 28 '18 at 13:43

After checking the SMART status, lets check your file system...

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

Update #1:

Rebuild initramfs...

In terminal...

  • sudo update-initramfs -c -k 4.13.0-43-generic # update initramfs
  • reboot # to version

Run memtest...

| improve this answer | |
  • I ran the update-initramfs command. No errors were reported and I have successfully booted the laptop 15 times in a row with the 4.13.0-43-generic kernel. It seems to be behaving now. Thank you. – sunflowerastro May 28 '18 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.