1

Installation screen

It says it need libqt5core5a 5.7.0, but I can't upgrade to it

$ sudo apt-get install libqt5core5a
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5core5a is already the newest version (5.5.1+dfsg-16ubuntu7.5).
0 upgraded, 0 newly installed, 0 to remove and 70 not upgraded.

installing with dpkg -i command

$ sudo dpkg -i virtualbox-5.2_5.2.12-122591~Ubuntu~trusty_i386.deb 
dpkg: warning: downgrading virtualbox-5.2:i386 from 5.2.12-122591~Ubuntu~yakkety to 5.2.12-122591~Ubuntu~trusty
(Reading database ... 227029 files and directories currently installed.)
Preparing to unpack virtualbox-5.2_5.2.12-122591~Ubuntu~trusty_i386.deb ...
Unpacking virtualbox-5.2:i386 (5.2.12-122591~Ubuntu~trusty) over (5.2.12-122591~Ubuntu~yakkety) ...
dpkg: dependency problems prevent configuration of virtualbox-5.2:i386:
 virtualbox-5.2:i386 depends on libc6 (>= 2.15).
 virtualbox-5.2:i386 depends on libcurl3 (>= 7.16.2).
 virtualbox-5.2:i386 depends on libdevmapper1.02.1 (>= 2:1.02.20).
 virtualbox-5.2:i386 depends on libfontconfig1 (>= 2.9.0).
 virtualbox-5.2:i386 depends on libfreetype6 (>= 2.2.1).
 virtualbox-5.2:i386 depends on libgcc1 (>= 1:4.1.1).
 virtualbox-5.2:i386 depends on libgl1-mesa-glx | libgl1.
 virtualbox-5.2:i386 depends on libglib2.0-0 (>= 2.12.0).
 virtualbox-5.2:i386 depends on libice6 (>= 1:1.0.0).
 virtualbox-5.2:i386 depends on libpng12-0 (>= 1.2.13-4).
 virtualbox-5.2:i386 depends on libsdl1.2debian (>= 1.2.11).
 virtualbox-5.2:i386 depends on libsm6.
 virtualbox-5.2:i386 depends on libssl1.0.0 (>= 1.0.0).
 virtualbox-5.2:i386 depends on libstdc++6 (>= 4.6).
 virtualbox-5.2:i386 depends on libvpx1 (>= 1.0.0).
 virtualbox-5.2:i386 depends on libx11-6.
 virtualbox-5.2:i386 depends on libx11-xcb1.
 virtualbox-5.2:i386 depends on libxcb1 
dpkg: error processing package virtualbox-5.2:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (229-4ubuntu21.2) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for hicolor-icon-theme (0.17-1~elementary0.4.1) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1+elementary2~ubuntu0.4.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 virtualbox-5.2:i386
  • What version of Ubuntu are you using? I'm assuming 17.04. – Dave May 27 '18 at 20:53
  • Ubuntu 16.04.3 LTS – Anoop Yadav May 27 '18 at 20:55
1

I don't know where you got the program that you ran and took a screenshot of. But in direct response to your question title (Installing Virtual Box 5.2), installing the latest version of Virtual Box (as well as many programs) are as easy as going to the official site of the application you want to install.

In this case, the official site of Virtualbox is http://www.virtualbox.org.

On this site, you have a download link on the left panel. Clicking on the download link will take you to the available downloads. All of the currently supported versions of Ubuntu are included in the list.

Clicking on the correct link will download the 5.2 Virtual box version (which is the latest). The download will be a *.deb package, which you can install by double clicking the download, or runnning this from the terminal:

$ dpkg -i [downloaded package name].deb
  • I had downloaded wrong version but with right version it is still giving error ouput is update above. – Anoop Yadav May 27 '18 at 21:08
  • Run these commands to resolve the errors. 1) sudo apt update 2) sudo apt upgrade, 3) sudo apt install -f. – L. D. James May 27 '18 at 21:11
  • dpkg: error processing package virtualbox-5.2:i386 (--install): dependency problems - leaving unconfigured – Anoop Yadav May 27 '18 at 21:18
  • libvpx1 is the dependency which is missing – Anoop Yadav May 27 '18 at 21:19
  • Is the error you describe the results of running sudo apt install -f after running the other two commands? Did the other two commands give any errors? – L. D. James May 27 '18 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.