4

Problem: My laptop battery is broken, it never charges. I have to use it at 0% battery and on AC power. Ubuntu 18.04, keeps giving me annoying notification every 5 seconds: enter image description here

I know several questions have been asked on this topic, but this is specifically for about Ubuntu 18.04. I have tried solutions mentioned for older versions of Ubuntu but none of them work:

  • Modifying /etc/UPower/UPower.conf
  • Modifying dconf editor ->org -> gnome -> settings-daemon -> plugins -> power

I am surprised that these settings don't point to the same values? I can set different values in these and still nothing happens. Do these settings even work or are they deprecated?

Has anybody else faced this issue? It's very annoying.

  • I use my laptop with the battery removed and get no warnings, does this work for you? – Broadsworde May 27 '18 at 10:18
  • 1
    That's not recommended as all the oscillations in electric current would spoil hardware. – Nikhil May 27 '18 at 11:00
  • I've not heard that before, do you have any reference documents/articles? I've been running my Samsung laptop without a battery for over 5 years without any hardware issues. – Broadsworde May 27 '18 at 11:14
  • 1
    Try setting org.gnome.settings-daemon.plugins.power use-time-for-policy false, then setting org.gnome.settings-daemon.plugins.power percentage-low and related settings to 0 – vanadium Sep 12 '18 at 17:01
  • 1
    @vanadium my gnome 3.28 dconf has none of these – Matthias Urlichs Oct 7 '18 at 10:17
2

I found these commands did the trick:-

~$ dconf write /org/gnome/settings-daemon/plugins/power/use-time-for-policy false
~$ dconf write /org/gnome/settings-daemon/plugins/power/percentage-low 0

you can check the dconf edit worked like so:-

~$ dconf dump /org/gnome/settings-daemon/plugins/power/
[/]
percentage-low=0
sleep-inactive-ac-timeout=3600
sleep-inactive-ac-type='nothing'
use-time-for-policy=false

@vanadium provided the correct keys and values to update. The keys were missing from my dconf but adding them seems to have solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.