2

I messed up by running a mv command on the entire contents of an old external drive to my Desktop without making a destination folder first.

I ran

sudo mv /my/external/path/* /home/myself/Desktop/

when instead I should have made a directory on Desktop first.

I wasn't thinking, and my Desktop was filling up behind my full screen terminal while I walked away unbeknownst to me. I had 3 important folders on it (School, Dev Projects, and CODE), all of them with many subdirectories. Well, they're gone, and I cannot find them. To compound the situation, I didn't realize that my computer didn't have enough space to complete the job, so not everything was copied.

If I did not manually delete these folders, where could they have gone? I checked /home/myself/.local/share/Trash/files and found nothing.

I ran

grep -nr "Some_Folder_or_File_Names" 

on the newer external I copied to, and found nothing.

If these folders are lost, I just lost over a year of development projects and school material.

Thanks.

closed as off-topic by steeldriver, John1024, David Foerster, Fabby, karel May 27 '18 at 9:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – steeldriver, John1024, David Foerster, Fabby, karel
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Look in the /home/myself/Desktop-folder. – mook765 May 26 '18 at 16:59
  • Your grep searches the text Some_Folder_or_File_Names whithin the files. It doesn't match filenames. Try find . -name "*Some_Folder_or_File_Names*" instead. – PerlDuck May 26 '18 at 17:00
  • Did that too after posting this. Nothing. Even did ls -a. – IRGeekSauce May 26 '18 at 17:00
  • Ok tried the "find" command. Nothing. – IRGeekSauce May 26 '18 at 17:03
0

I rebooted and voila! That was weird. O.o

  • Warning: Self-answer! Do not close answer! VTC Q instead! – Fabby May 26 '18 at 19:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.