16

I am trying to understand why Pulse secure installed via Debian package is not starting at all.
I am able see it in the GUI menu, when clicked the Menu disappears and now the application should start, but it doesn't.

In terminal with Sudo access I type pulse and hit enter, but this doesn't execute it.

root@user:/home/user# pulse 
Command 'pulse' not found, did you mean: 
  command 'apulse' from deb apulse 
Try: apt install <deb name>

List of Applications Shows a different name:

root@user:/home/user# ls -lh /usr/share/applications | grep pulse
-rwxr-xr-x 1 root root  285 Aug 29  2017 pulseUi.desktop

What's confusing me is while removing this package I am able to see this in terminal.

user@user:~$  sudo apt remove pulse
pulse                        pulseaudio                   pulseaudio-module-bluetooth  pulseaudio-utils

Additional Information:

uname -a
Linux user 4.15.0-22-generic #24-Ubuntu SMP Wed May 16 12:15:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Appreciate your time already in reading the details above.

2 Answers 2

20

Executing the command inside the pulseUi.desktop file. I get the following error:

/usr/local/pulse/pulseUi:error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

The error is caused by the missing library libwebkitgtk-1.0.so.0. I solved the problem by installing the following package

sudo apt-get install libwebkitgtk-1.0

Update: On another Ubuntu 18.04 workstation, I have to install the libgnome-keyring0 as well.

The general solution is to execute the executable file, e.g. /usr/local/pulse/pulseUi. Then install all the missing libraries that are reported in the error messages.

2
  • 1
    This seemed to work for me, now I can open the application Aug 29, 2018 at 9:18
  • For me this almost worked but, perhaps due to an older version of the installer, I had to use "sudo apt-get install libwebkitgtk-1.0:i386" .
    – aap
    Oct 9, 2018 at 19:56
9

In the Ubuntu Version 18.04, You could install Pulse Secure, post download, using the below command:

$ sudo dpkg -i /home/{user}/Downloads/ps-pulse-linux-9.0r2.0-b819-ubuntu-debian-64-bit-installer.deb

Followed by installing the below required dependencies:

$ sudo apt-get install libwebkitgtk-1.0.0
$ sudo apt-get install libproxy1-plugin-webkit
$ sudo apt-get install libgnome-keyring0
2
  • Where can I download the deb file from? I can't find it anywhere.
    – frakman1
    Apr 13, 2020 at 20:38
  • You could download it from: pulsesecure.net/trynow/client-download. You'll have to register yourself. You'd get the download link via an email at your registered email ID. Apr 15, 2020 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.