7

I have NUC 7PJYH with Intel wireless AC-9462 card. The problem is that systems randomly freezes when using WiFi. There are no freezes when wifi is disabled. I tried to use different kernels, but still the same behaviour.

I investigated dmesg when I was on kernel 4.16.12 and I found that the kernel is asking for iwlwifi-9000-pu-b0-jf-b0-35 and iwlwifi-9000-pu-b0-jf-b0-36 firmware files. I tried to find these files on wireless.wiki.kernel.org. I went through all repositories they maintain and I found only versions 34 and 38 of this firmware.

Where can I find the correct firmware for kernel 4.16? These files are not even in the official linux-firmware package tree.

EDIT:

wifi related dmesg output:

[    3.476177] iwlwifi 0000:00:0c.0: enabling device (0000 -> 0002)

[    3.483822] iwlwifi 0000:00:0c.0: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-36.ucode failed with error -2

[    3.483839] iwlwifi 0000:00:0c.0: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-35.ucode failed with error -2

[    3.497077] iwlwifi 0000:00:0c.0: loaded firmware version 34.3125811985.0 op_mode iwlmvm

[    3.570636] iwlwifi 0000:00:0c.0: Detected Intel(R) Dual Band Wireless AC 9462, REV=0x318

[    3.624572] iwlwifi 0000:00:0c.0: base HW address: 68:ec:c5:9c:38:3f

[    3.685419] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'

[    3.974259] iwlwifi 0000:00:0c.0 wlo1: renamed from wlan0

[    4.856976] iwlwifi 0000:00:0c.0: Conflict between TLV & NVM regarding enabling LAR (TLV = enabled NVM =disabled)
1
  • I would like to add that the error message about missing firmware is not there with kernel 4.15 because it uses iwlwifi-9000-pu-b0-jf-b0-34 which is available in 18.04. But system hangs as I wrote in the original post. That is the reason I'm trying to upgrade kernel. May 26 '18 at 10:32
4

I believe that the reason that you nor I can find any x.35 or x.36 firmware with a thorough web search is that they don't yet exist. The driver in question, iwlwifi, is written to look for the latest firmware version first; failing to find it, look for the next latest and so on until a suitable firmware file is found.

At the same time, the driver is written to automatically use later firmware versions as they are developed and included in newer versions of linux-firmware. In other words, when x.35 is written and released, the driver iwlwifi will find and use it without the necessity of a newer version of the driver. This is quite common in Intel and some other wireless drivers.

I think there is some reason other than firmware that causes your system to hang when using wireless. I invite you to ask a new open-ended question and include: dmesg | grep -e iwl -e wlp.

EDIT: We see this clue in your dmesg:

Conflict between TLV & NVM regarding enabling LAR (TLV = enabled NVM =disabled)

I suggested that you try a driver parameter:

sudo modprobe -r iwlwifi && sudo modprobe iwlwifi lar_disable=Y

It seems to have solved the hang issue so I suggest that you make it permanent:

sudo -i
echo "options iwlwifi lar_disable=Y"  >>  /etc/modprobe.d/iwlwifi.conf
exit

You should be all set.

7
  • Thank you for your answer. I saw in the log that x.34 was used instead, so I'm using still the same firmware with different kernels. What is confusing is that I was able to find x.38 of this firmware; but as you wrote, x.35 and x.36 have not been released yet. May 26 '18 at 14:52
  • I believe, based on using and studying Intel wireless devices exclusively for about 15 years, that the very high firmware numbers like x.38 that are not even referenced in the driver; e.g. modinfo iwlwifi | grep firm are experimental, bleeding edge firmware versions.
    – chili555
    May 26 '18 at 15:06
  • Thanks for explanation. I added my dmesg output into the original question. So I will wait for new kernel/firmware because I believe there must be some bug. What is weird is that system hangs only when streaming video e.g. from youtube. My first guess was GPU issue, but as I wrote, it works perfectly on wired network. May 26 '18 at 15:18
  • 1
    Please try: sudo modprobe -r iwlwifi followed by: sudo modprobe iwlwifi lar_disable=Y and test. If it helps, I'll add it to my answer, making it persistent.
    – chili555
    May 26 '18 at 15:37
  • 1
    Testing it 10 minutes and so far so good. I usually saw system freeze in less than one minute when streaming video. It seems you solved my problem! How come this helped? May 26 '18 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.