2

I'm trying to install mssql-server on Ubuntu;

I did all these steps on microsoft.com.

And I get the message:

$ sudo apt-get install -y mssql-server
...
The following packages have unmet dependencies:
 mssql-server : Depends: openssl (<= 1.1.0)

But I already have openssl=1.1.0g-2ubuntu4, and i think that is OK to go with this version of openssl. How can I skip this check?

  • Which Ubuntu version is this you try this on? – Videonauth May 26 '18 at 11:08
  • @Videonauth that is Ubuntu 18.04 LTS. – Nikita Kal'chenko May 26 '18 at 13:37
  • Well i guess you got an already working for you answer right now? – Videonauth May 26 '18 at 13:38
  • @Videonauth now it provides conflicts, so it was removed with apt-get --fix-broken, I will reinstall it later. – Nikita Kal'chenko May 26 '18 at 13:45
  • O.k. when you do, please provide any maybe showing up conflicts by doing an edit of your question then, so either I can write you an answer or the current answerer can update his. As far i can see the biggest problem is, that this package was made for Ubuntu 16.04 and that there is no package yet for 18.04. – Videonauth May 26 '18 at 13:49
3

Looks like Microsoft did not update their package MSSQL. Since openssl has got important fixes recently I would not try to ignore the dependency.

I recommend to install mysql-server instead of mssql.

If you still want to install mssql this is the way to go:

apt download mssql-server

dpkg --ignore-depends=openssl -i mssql-server.deb

| improve this answer | |
  • sudo apt-get install mssql-server --nodeps – kukulo May 26 '18 at 10:16
  • or --no-install-recommends – kukulo May 26 '18 at 10:17
  • 1
    With --no-install-recommends I get the same erroneous output, it seems like it does nothing. --nodeps flag is not available. – Nikita Kal'chenko May 26 '18 at 10:52
  • apt download mssql-server then dpkg --ignore-depends=openssl -i mssql-server.deb . replace the mssql-server.deb with the filename that the apt downloads. – kukulo May 26 '18 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.