1

I am trying to install Ubuntu in an Acer Aspire Switch10e windows tablet. It has an Intel Atom Z3735F CPU.

It is a 64bit processor but it only supports UEFI 32 bits, that makes it so none of the isos I have tried work directly to boot. The workaround for this was using the isorespin script on a Xubuntu-18.04-64bit image using the command:

isorespin.sh -i xubuntu.iso -u --atom

This gets me to the live version and allows me to install. But it doesnt seem to install a 32bit grub since the tablet wont detect a bootable media afterwards.

I have managed to launch the installation by using the following lines in the liveUSB grub console:

linux /casper/vmlinuz root=/dev/mmcblk1p2
initrd /casper/initrd.lz
boot

And here is where I am at. I don't know how to install a 32bit bootloader from here that lets me launch without having to use the liveUSB. The guide I was following mentioned the use of the package grub-efi-ia32. But running this

sudo apt-get install grub-efi-ia32
sudo grub-install /dev/mmcblk1

and rebooting doesn't seem to work.

EDIT: I managed to get it to boot without the live usb, but not automatically.

The instalation left me with a EFI partition, wich contained the folders EFI/ubuntu and EFI/BOOT

I deleted the files bootia32.efi and BOOTx64.EFI from EFI/BOOT and replaced with the identically named files from the live usb. I also copied the file grubx64.efi from usb/EFI/BOOT.

I also copied the whole boot/ directory into the tablet's efi partition and the files vmlinuz and initrd.lz from the usb.

After doing this, the same menu as if I had the liveUSB connected appeared and I could manually type the commands above to launch.

I edited the grub.cfg file so it only had one menu entry that executed the orders above and now it launches.

But I have no real clue why and if someone wants to explain me what the heck did I just do I would apreciate it.

4
  • Normally the versions you use to boot installer are not same as version used after install as they include more features. Installer version is what is mimimally required to boot the installer, not full system. But with your bootia63.efi it may be the same? Similar systems: askubuntu.com/questions/775498/… & askubuntu.com/questions/392719/32-bit-uefi-boot-support
    – oldfred
    May 26, 2018 at 14:23
  • Can you share your configuration file (and structure?). This sounds like the only way. I also do not have the EFI images on my ISO :(
    – chx101
    Jul 31, 2019 at 16:20
  • @chx101 I did not copy the files from the iso but from the usb boot partition. Still, I just installed ubuntu 19.04 gone through isorespin on the tablet and added the uefi32 files to "trusted executables" in the bios and it launched fine without copying anything new.
    – metichi
    Aug 16, 2019 at 12:29
  • @metichi My problem was solved. All I had to do was install a 64-bit OS version instead. I installed Lubuntu 18 LTS which comes with EFI support by default and it worked without problems.
    – chx101
    Aug 17, 2019 at 0:04

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.