9

I am having problems on a Cisco VPN.

ISSUE: Unable to open "Cisco Anyconnect Secure mobility client" on my Ubuntu 18.04 LTS after the complete installation.

I am able to see the icon on the application menu; but, when I launch the app it doesn't open. Below is the screenshot \ logs for your reference:

Screenshot of terminal logs

17

I had the exactly same problem, the VPN was working but couldn't see the GUI, I found that is because of some missing dependency (libpangox-1.0-0 and libcanberra-gtk-module), try installing it:

sudo apt install libpangox-1.0-0 libcanberra-gtk-module

You may check if you need anything more or have other errors by running the UI executable, mine was installed on

/opt/cisco/anyconnect

You can run bin/vpnui and check what error you may have, hope it helps!

  • 1
    Hello Kennedy, Thanks for helping me out. I am able to see the GUI after installed the dependency. Really appreciate your support. Long live linux :-) – Harinaath Jun 28 '18 at 2:01
  • Hey @Harinaath! Your welcome! I'm glad it worked! Please mark this answer as the correct one, so other people will know that actually solved your problem :) – Kennedy Oliveira Jun 28 '18 at 2:20
  • Done and Sorry for the late response. Cheers ! Harinaath – Harinaath Jun 29 '18 at 13:49
0

I also installed sudo apt install libgtk2.0-0 which fixed the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.